Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX OpenGL performance is terribly slow on Windows 10
#1
After installing Windows 10 I see GSDX OpenGL version runs 10-20 times slower than it was on Windows 8.1. For example, I have ~ 2.5 fps in Tekken 5 US NTSC version (it should run at 60 fps). Direct3D version still gives me good performance.
I tried different OpenGL applications on Windows 10 and I don't see the same bad performance.
I have GeForce GTX 960 with NVIDIA driver 353.62. I use latest git build of PCSX2.
Reply

Sponsored links

#2
I'll get my hands on windows 10 and check it out. 2.5 fps is too low , what level do you have your blending unit accuracy on ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
I tried all levels. Even the fastest one didn't give me better results.
Reply
#4
please provide the content of your GSDX.ini file.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
[Settings]
AllowHacks=1
ModeWidth=1280
ModeHeight=1024
ModeRefreshRate=60
Renderer=3
Interlace=7
AspectRatio=0
upscale_multiplier=4
windowed=0
filter=1
paltex=1
vsync=0
logz=1
fba=1
aa1=1
nativeres=0
resx=1920
resy=2160
swthreads=3
msaa=0
UserHacks_AlphaHack=0
UserHacks_HalfPixelOffset=0
UserHacks_SkipDraw=1
extrathreads=2
ShadeBoost=0
UserHacks=1
UserHacks_MSAA=0
UserHacks_SpriteHack=0
UserHacks_WildHack=0
Adapter=10DE:1401:85261043:A1
MaxAnisotropy=16
AnisotropicFiltering=1
Fxaa=1
shaderfx=1
UserHacks_AggressiveCRC=0
UserHacks_AlphaStencil=0
UserHacks_NVIDIAHack=0
UserHacks_DisableCrcHacks=0
UserHacks_TCOffset=32768500
crc_hack_level=3
UserHacks_round_sprite_offset=0
Userhacks_align_sprite_X=1
accurate_blend=1
accurate_date=1
accurate_colclip=1
texture_cache_depth=1
accurate_fbmask=1
shaderfx_conf=shaders/GSdx_FX_Settings.ini
shaderfx_glsl=shaders/GSdx.fx
ShadeBoost_Contrast=50
ShadeBoost_Brightness=50
ShadeBoost_Saturation=50
accurate_blending_unit=1
Reply
#6
And please show emulation settings. Sounds to me like interpreter or synchronized gs.
Reply
#7
(08-02-2015, 02:02 PM)willkuer Wrote: And please show emulation settings. Sounds to me like interpreter or synchronized gs.

Emulation settings are normal. I still have 60 fps in Direct3D11 mode.
Reply
#8
The Renderer is set to D3D11(hardware mode) in the INI file. also some old variables are still present in the file, please delete the GSDX.ini file and try once again.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#9
After removing ini file the OpenGL performance reverted to normal. Thanks!
Reply
#10
No problem, it was just some old deprecated variables in the INI file causing problems.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply




Users browsing this thread: 1 Guest(s)