Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX Problem :(
#1
Hey Guys! So I've had Pcsx2 on all of my previous computers, and I just got a new one. I have Windows 7 Professional on it at the moment, and PCSX2 works fine. Well, besides GSdx of course. Every time I try to load a game, I get a popup box, and it sends me to my Plugin/BIOS Configuration menu, and it says I have a problem with GSdx every single time, no matter what version of GSdx i have. Can someone please help me with this issue?

Log :

Code:
Initializing plugins...
    Init GS
Windows 6.1.7600
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Standard VGA Graphics Adapter (6.1.7600.16385)
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primary Sound Driver' (Windows DirectSound)
*** Device 1: 'Speakers (High Definition Audio Device)' (Windows DirectSound)
*** Device 2: 'Digital Audio (S/PDIF) (High Definition Audio Device)' (Windows DirectSound)
*** Device 3: 'Speakers (High Definition Audio Device)' (Windows WASAPI)
*** Device 4: 'Digital Audio (S/PDIF) (High Definition Audio Device)' (Windows WASAPI)
*** Device 5: 'Speakers (HD Audio Headphone/Speakers)' (Windows WDM-KS)
*** Device 6: 'SPDIF Out (HD Audio SPDIF out)' (Windows WDM-KS)
    Opening CDVD
* SPU2-X: PortAudio error: Invalid device
isoFile open ok: C:\Users\Remnant\Desktop\Kingdom Hearts II - Final Mix+ (Japan).iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2114352 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Standard VGA Graphics Adapter (6.1.7600.16385)
Closing plugins...
    Closing DEV9
(pxActionEvent) GS plugin failed to open!(thread:MTGS)(thread:EE Core)    
Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
    Closing PAD
    Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
[wx] Failed to load shared library 'C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx-r5875.dll' (error -1073741795: unknown error c000001d)
Path: C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx-r5875.dll
[wx] Failed to load shared library 'C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll' (error -1073741795: unknown error c000001d)
Path: C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
Need a Plugin? - Just ask!
Reply

Sponsored links

#2
Hello,

i don't know this error but i have some ideas.
You said it's a new computer, so i would try the following first:
1. Can you check your device manager and see if there are missing drivers or drivers that don't work properly (marked with a yellow triangle with a "!" on it)?
2. You can try to update Direct X.
Reply
#3
Your CPU might not have supported AVX try using sse4.1,sse3,sse2.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
(01-29-2015, 04:05 AM)ssakash Wrote: Your CPU might not have supported AVX try using sse4.1,sse3,sse2.

That was my first thought too but he wrote:
(01-29-2015, 01:47 AM)MurkySquad Wrote: Every time I try to load a game, I get a popup box, and it sends me to my Plugin/BIOS Configuration menu, and it says I have a problem with GSdx every single time, no matter what version of GSdx i have.

He shouldn't be able to select this plugin, if his CPU dosn't support AVX (as long as he didn't edit the ini file directly)


@ MurkySquad:
Please let us know witch CPU you have. Then we can say for sure if you are using the right (or wrong) plugin.
Reply
#5
Update directx. That's almost certainly the issue.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
Hey everyone, I figured it out. It wasn't a DirectX issue, I just needed to apply some updates with my graphics card and things like that. Thank you all for contributing. I am going to stay on this forum now. I appreciate it!
Need a Plugin? - Just ask!
Reply




Users browsing this thread: 1 Guest(s)