Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDx 0.1.16 problems
#1
Xubuntu 13.04
i7 @ 3.4Ghz
6gig ram
GTX 295 (offical nvidia driver 325.15)
PCSX2 1.1.0.0(svn) [from Gregory's PPA]

Hi all.

When using the GSDx (0.1.16) plugin on linux it starts at 60 fps but by the time it gets to the first frame of the bios animation it drops to 1fps and effectively halts the emulation. When using the ZZ ogl pg 0.4.0 plugin it does boot into game fine but never really exceeds 15 fps.

In Windows, PCSX2 runs really well with quite high frame rates so I am fairly confident that it isn't my rig causing issues. I appreciate that linux support is still very much in development so comparing to Windows is not a very fair comparison.

What graphics plugin does everyone else use? does anyone else have this emulator running a usable frame rate or is it too early in development to expect usable speeds?

Thanks
Reply

Sponsored links

#2
Try using fast boot. For some reason even with fast boot it will bring you to the BIOS screen. If it does that, try doing fast boot again. It will work and enable you to skip the BIOS screen and go to the game itself. For some reason Linux version of pcsx2 can get stubborn.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
Fast boot does allow it to get to the konomi logo without halting but it becomes a 3 FPS slideshow.

I ran it from Terminal and got the following which kinda gives an idea of what might be wrong:

glX-Version 1.4 with Direct Rendering
Failed to find glCLearTexImage
Failed to find glBindTextures
Failed to find glBufferStorage
Failed to find glGetTextureSamplerHandleARB
Failed to find glMakeTextureHandleResidentARB
Failed to find glMakeTextureHandleNonResidentARB
Failed to find glUniformHandleui64vARB
Failed to find glProgramUniformHandleui64vARB
Supported Opengl version: 3.3.0 NVIDIA 325.15 on GPU: GeForce GTX 295/PCIe/SSE2. Vendor: NVIDIA Corporation
Buggy driver detected. Geometry shaders will be disabled

INFO: GL_ARB_gpu_shader5 is not supported
INFO: GL_ARB_shader_image_load_store is not supported
INFO: GL_ARB_clear_texture is not supported
INFO: GL_ARB_buffer_storage is not supported
INFO: GL_ARB_shader_subroutine is not supported
INFO: GL_ARB_multi_bind is not supported
INFO: GL_ARB_bindless_texture is not supported

GSDx in software mode does work suprisingly well until I get into game and it runs at around 20 FPS.

Given the information above i guess it is down to poor Nvidia driver support possibly coupled by the fact that a GTX295 is effectivly an SLi configuration....
Reply
#4
I guess "buggy driver" says it all. Perhaps try the open source driver. Eventually Gregory will weigh in and perhaps have you try a patch. I will say this is strange because I thought the Nvidia issues have been fixed.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#5
buggy driver is only for geometry shader which barely impact performance normaly.

Did you have issue with all games or only one (which one exactly by the way)
Reply
#6
(09-21-2013, 11:04 AM)gregory Wrote: buggy driver is only for geometry shader which barely impact performance normaly.

Did you have issue with all games or only one (which one exactly by the way)

Hi Gregory,

Thanks for your reply. I have 3 games to test it with and all fail in the same way when gsdx is set to "hardware". I see the first frame of the bios animation and then the frame rate drops to 1 FPS. I mainly use Metal Gear Solid 2 for testing.

Software mode does allow it to boot fine but the frame rates are not so good.

I use gkrellm to monitor my CPU usage and noticed that 1 core is locked at 100%. The author of the FS-UAE emulator told me that Nvidia drivers have a known issue with the way they handle wait loops which causes v-sync in any application to thrash the CPU. I am unsure if this issue is related to the problem or not.

Is there a way to run debug to give you a better idea of what is going on?
Reply
#7
Maybe you can try to disactivate vsync. It could be a SLI issue also.
Reply




Users browsing this thread: 1 Guest(s)