Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx black screen with hardware renderer
#1
Hi with the latest git version i can no longer use the hardware render in GSdx I only got a black screen with the sound still working. No problem with the software renderer. No error output in the console.
I am under manjaro using the nvidia driver.
xorg-server 1.17.4
linux43-nvidia 1:352.63
Reply

Sponsored links

#2
When does the problem appears exactly?
Reply
#3
I can't really tell i don't use pcsx2 really often and just rebuild it now because of the gcc upgrade and the abi change.
Reply
#4
In fact when i set opengl hardware I got :
Opening plugins...
Opening GS
(thread:MTGS) Calling pthread_create...
Current Renderer: Null (Null mode)
glX-Version 1.4 with Direct Rendering

And when i set opengl sotware mode i got :
Opening GS
Current Renderer: OpenGL (Hardware mode)
glX-Version 1.4 with Direct Rendering
OpenGL information. GPU: GeForce GTX 750 Ti/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 352.63
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_separate_shader_objects is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_copy_image is available
INFO: GL_ARB_buffer_storage is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_clip_control is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
Reply
#5
are you sure that you driver is correctly installed. Could you post the emulog please.

ok. Current Renderer: Null (Null mode) seem the issue.
Reply
#6
Yeah i dont know why I have to set opengl software to use the opengl hardware, and setting the opengl hardware use the null mode.
Reply
#7
Really? Did i do something wrong?
So you set renderer in the config and you get the wrong one as result? Or do you play with the ini?
Reply
#8
Yeah setting software i got hardware, setting hardware i got null. No i didnt touch the ini just using the gui to set the plugin.
Reply
#9
That's probably my fault. I will check that. I probably can fix it today in the evening.
Reply
#10
Hum, ok I understood the bug. I will fix it.

the issue is the removal of openCL
Reply




Users browsing this thread: 1 Guest(s)