Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx graphic bug on Windows 10
#1
As the tittle says, there is a graphic bug with pransparent textures in windows 10, that glitch presents only with GSdx rendering in DX 11, it is not present in the same setings on Dx9.

Here a a picture comparin DX11 with DX 9, those transparent textures constantly blink to a black gloss texture, it also afects shadows in games.

I have tested various builds and it occurs on any of them....currently i´m in build 1.3.1-20150801132925 with AMD Phenom X4 and Nvidia Geforce GT 545 with 353.62 drivers


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
Please try the latest stable release 1.2.1 as well.
Please post your settings (eg. by screenshots) of pcsx2 (all tabpages) and gsdx plugin.
Reply
#3
AS far as I can tell. This effects A LOT of games. Mainly 90% of my library. I am not worried about it and give it time considering it has been 2 days since official launch.
MOBO - ASUS Maximus VII Hero
CPU - Intel i7 4790k 4.4GHZ
RAM - 16 Gigs DDR3 2133mhz
HDD - 3 500 Gig SSD 1 3 TB 7200 RPM
GPU - EVGA Nvidia GTX 1070 SC
OS- Windows 10.
Reply
#4
using official build, running on GSDX directX 11, no bug like yours so check your stuff

http://s10.postimg.org/u48ylzcpl/Untitled.jpg
Reply
#5
Here are my settings.

To take a note, all these setings are just the same i had when i was in windows 7, 3 days ago, with these same setings, a ran the emulator on windows 10, and the bug appeared (in windows 7, with GDSX in DX11, there was no error like this).

There is a picture with the same graphic settings for the GDSX plugin but in DX 9, where the problem is nowhere to be seen, only happens in DX11.

Hope this have a good explanation, because, is rare that the same plugin works odd in one version than another....whit 2 diferent OS's.


Attached Files Thumbnail(s)
                               
Reply
#6
I have to correct...............only the Open GL version of GDSX is working well....................

Now results that working with GDSX in dx9 version only bring me black screen, and actually shows something when pausing a game

The other two shots shows what hapends in GDSX 11, with the blinking graphics,


Attached Files Thumbnail(s)
           
Reply
#7
(08-02-2015, 08:55 AM)shimazakid Wrote: Here are my settings.

To take a note, all these setings are just the same i had when i was in windows 7, 3 days ago, with these same setings, a ran the emulator on windows 10, and the bug appeared (in windows 7, with GDSX in DX11, there was no error like this).

There is a picture with the same graphic settings for the GDSX plugin but in DX 9, where the problem is nowhere to be seen, only happens in DX11.

Hope this have a good explanation, because, is rare that the same plugin works odd in one version than another....whit 2 diferent OS's.

You enabled hardware hacks in GSdx. What hacks are you running?
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#8
Well I don't have win 10 and I guess most user here dont have so far but this bios screen is easily checkable. Is there anybody with win10 who can check if the bios screen is broken in dx11 but works in dx9 and possibly ogl? Nobbs? Ref?
Reply
#9
Tempted to install Windows 10 on my laptop.. Just for testing purposes. It has 8.1 atm.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#10
(08-02-2015, 10:41 AM)Ryudo Wrote: You enabled hardware hacks in GSdx. What hacks are you running?

Actually NONE,


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)