Poll: Well?
This poll is closed.
Yes, damn it.
2 33.33%
No u fool.
4 66.67%
Total 6 vote(s) 100%
* You voted for this item. [Show Results]

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx r1360+ is no good (with GMA).
No joke...for me that is. With my GMA950 and C2D under 2ghz, I could easily get 80fps in FFX with the latest beta and speed hacks... provided I use r1357 (and lower versions) of GSdx.

r1360+ GSdx don't work at all with my trusty GMA950, showing a blank screen.

r1549+ (with 'gma fix') actually crash the plugin completely with 0xffffffff.

Ok fine. I resolved to use 3Danalyzer to emulate "HW TnL caps" because Intel's TnL bit is a bit funky. So I got graphics, but they were all crappy and garbled. Fast as all heck...but crappy and garbled, missing backgrounds and textures, etc. The rocks kept flickering strange colors too. Bad!

Help...? Do the devs (COUGHgabestCOUGH) just need a GMA950? (This is one of the most common graphics chips in the world ya know. Integrated and all that.)

Sponsored links

Here's the bad messages, w00t.
[Image: messagess.png]
It is a known issue and was attempted to be fixed in some of the later revisions. Get one from the GSDX thread in the Discussion and Support forum.

Don't expect huge speed increases, either. Newer doesn't necessarily mean faster or better, just different.
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
The GMA fix presented in r1549 is rejected by the GMA, and throws this error before the game window appears:
[Image: gmafix.png]

The last working revision was r1357. The next available revision, r1360, crashes due to missing deps. All revisions thereafter showed the bug, which was no output (black screen). r1549 and up all crash with 0xffffffff.
Have you updated your DirectX to the latest revision? (March 2009)

That's a typical cause of that error message.

Also, if you are running Vista/Win7, you'll need to run as admin.
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Don't worry, I'm quite sure it's not my setup. Smile Yeah, I updated DX just earlier that day (and tried again later). And nope, just XP.

The error disappears when I run with emulated HW TnL caps via 3DAnalyzer, but the graphics are unbelievably screwy then.
Looking back the revisions, there was a change in r1340 that could trigger error X5426. Are you sure 1340 works as good as 1339-?
well i don't have that game but i have an Intel GMA and it works for me Mellow, but this might be unrelated but do you have the Visual C++ SP1 Redist package installed? Smile

EDIT: and looks like i get fullspeed now in Sora's battle using windowed mode Smile (when in r1479 in windowed mode it was like 30-40fps >_>)
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
@Gabest: Revision 1339 and lower are much better; with 1340+ there are bad texture glitches (shifting/missing textures). So r1340+ is very glitchy but does produce output, until r1360+ which produces no output. Smile

Also, not all GMA's are the same: I have the popular GMA 950. With r1339 SSSE3, I almost achieve full speed in FFX in the latest PCSX2 beta (with speed hacks).

@LuisR14: Yes, I have VC++ 2005 SP1 and 2008 SP1.
I have a GMA 3100, gonna test it with older revisions later.
Any place where i can get them compiled?

EDIT: LuisR14, i have the same processors as yours, but an older GMA. What OS are you running?

Users browsing this thread: 1 Guest(s)