Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx r3878 blur in FFX
#1
I have noticed some blur when using the GSdx 3693 (MSVC 15.00, SSSE3) 0.1.16 [GSdx-ssse3-r3878] GPU plugin, where it is not present using GSdx (MSVC 15.00, SSSE3) 0.1.7 [GSdx-ssse3].

I would like to know if there is a solution to this? I would rather use the r3878 plugin because of speed, but the blur is a little annoying. It must be said, that not all parts of what is rendered have this blur.

Plugins and settings:
GS: See above for respective plugins, see below for settings in both of them
PAD: LilyPad svn (r3878) 0.10.0 [lilypad-r3878]
SPU2: SPU2-X r3702m 1.4.0 [spu2-x-r-r3878]
CDVD: cdvdGigaherz (r3429) 0.8.0 [cdvdGigaherz]
USB: USBnull Driver 0.7.0 [USBnull]
FW: FWnull Driver 0.6.0 [FWnull]
DEV9: DEV9null Driver 0.5.0 [DEV9null]

All plugins except GS/GPU are at their default settings, no speedhacks or fixes.

GSdx 3693 (MSVC 15.00, SSSE3) 0.1.16 [GSdx-ssse3-r3878] settings:
Renderer: Direct3D? (Hardware) - Doesn't matter if it is D3D9 or D3D10
D3D internal res: 2560 1600
Or use Scaling: 1x (Use D3D internal Resolution)
Or use original PS2 resolution: Native not ticked
Texture filterig, Allow 8-bit textures, logarithmic Z and Alpha correction are all ticked.

GSdx (MSVC 15.00, SSSE3) 0.1.7 [GSdx-ssse3] settings:
Resolution: 2560x1600 60Hz
Renderer: Direct3D? (Hardware) - Doesn't matter if it is D3D9 or D3D10 concerning blur
Shader: Pixels Shader 3.0
Interlacing: None
Aspect Ratio: Stretch
D3D internal res: 2560 1600 (Native not ticked)
NLOOP hack, Texture filtering, Wait vsync, Logarithmic Z, Alpha correction are all ticked, where Enable tv-out is not.

With both plugins full screen is used. Hardware that matters: Intel QX6700 @ stock 2.66 GHz and nVIDIA GTX 295 @ stock speeds.


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Well I know that setting the internal resolution too high has a ghosting effect but this looks like something else.

Silly question but you have got blur effect off yes?
CPU: i9 20Ghz 40-core
GPU: GTX 129000 in Octo-SLI
RAM: 64GB DDREKT69
Monitor: 800x600 15" CRT
Reply
#3
(11-09-2010, 05:18 PM)Fezzer Wrote: Well I know that setting the internal resolution too high has a ghosting effect but this looks like something else.

Silly question but you have got blur effect off yes?

Where is this blur effect setting located? It may not be a silly question.
Reply
#4
Tried unchecking texture filtering? Is it present if you check 'native'? Is it still there if you use DX9/10 software mode? A bigger pic would help more Tongue
[Image: newsig.jpg]
Reply
#5
(11-09-2010, 07:55 PM)Bositman Wrote: Tried unchecking texture filtering? Is it present if you check 'native'? Is it still there if you use DX9/10 software mode? A bigger pic would help more Tongue

Yeah, I tried that on your request and unchecking texture filtering didn't help. I cannot really tell if it present when 'native' is checked, or if it is there when using DX9/10 software mode, as the resolution is simply too low, but I suspect it is not present. Bigger pics:

Old GSdx
[Image: 7969Old-GSdx.jpg]

r3878 GSdx
[Image: 3194r3878-GSdx.jpg]

Both taken with internal resolution at 2560 1600 and full screen. I hope the blur effect is as obvious to others, as it is to me. I am some what certain it is not related to this thread because of two reasons:

1. Changing the SkipDraw setting doesn't make any difference to this particular blur, but it does remove the kind mentionen in that thread. That particular issue I also never noticed with the old GSdx.

2. The issue disappears, if I set the internal resolution to 2048 1536 and keep it in a 2048 1536 4:3 windows.

I suspect something goes wrong when having 2560 1600 internal resolution and using 2560 1600 full screen. I can live with the problem regardless, but it would be nice if I could get the best of both worlds (the speed of r3878, and the no-blur of the old GSdx) with my prefered settings.

Any suggestions?
Reply
#6
The problem is most likely that the game wants to do that blur (since it looks fine in native res).
Any GSdx revision or setting that doesn't show it is probably running into some rounding or offset problem.
It also could be that the blur detection GSdx has fails on this particular game.
I'll look into that when I have some more time.

For now try to recreate the condition where it works in windowed mode by testing different internal resolutions.
Also try the various scalers, they could work better.
Reply
#7
Try the offset hack using a scaling res.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
I'll try working with your suggestions and report back. Thanks.
Reply




Users browsing this thread: 1 Guest(s)