Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Game Slowdown Regardless of Settings
#1
Every game I've tested out is playable, but there's frequent times where the game goes into slow-mo for a few seconds, and it seems to happen when it's loading a new area of whatever game I'm playing, changing menus, or loading anything new at all. I used Fraps as a benchmark, and it seems to be consistantly at 57-60, with a few times when going into a loading screen where it dropped down to 45 for a split second. But for the most part, Fraps says I'm at a decent FPS even with the slowdown. There's certain areas of a level I can go to (Tony Hawk 3's Canada level for instance) where the game feels like it's dropping to ~40 FPS, but Fraps says I'm still at 60. Whatever.

The music seems to slow down with it. Constant speeding up/slowing down can grate on your nerves pretty quickly.

I've tried every plugin, every setting (both hardware and software), tried every resolution including native, and the problem is there. Even with native resolution with literally every tweak turned off. However, if I crank the settings up to 1080p on hardware, turn on all enhancements, and crank up AA, it's EXACTLY the same. Not better, not worse, but the same. It just looks nicer now. Changing the speedhack presets don't make a difference, except for setting it anything above balanced makes Tony Hawk 3's graphics glitch to where it's unplayable. So I keep it at balanced.

Anyone have any ideas? I've tried moving my ISOs to a different internal hard drive, since that fixed a similar issue I had with Dolphin (which runs PERFECTLY now) but this problem persists. I've tested it with Tony Hawk's Pro Skater 3, Frequency, and 007 From Russia With Love. They're all my own rips I made with IMG Burn. I can understand game slowdown due to an old video card, especially since it slows down the most when I'm in a level with a lot of graphic detail, but why isn't it affected for better or worse when I change my settings? I feel like my card should be decent enough anyway.

Here are my specs:

Intel i5 3350P @ 3.10 ghz
8 GB RAM
Windows 8.1 64-bit
Nvidia GeForce 750ti
PCSX2 1.2.1
Reply

Sponsored links

#2
My guess is that your CPU is causing a bottleneck at occasional key points where a lot of CPU calculations are required. Stuff like higher resolution and AA mostly just taxes your GPU, so that's why adding on all that isn't slowing it down more than it already is. My CPU is the same clock speed but it's somewhat newer and it runs into some bottlenecks on some CPU heavy games so I can believe your CPU causing some bottlenecks.
Reply
#3
Yikes. I'm assuming my only chance at improving this is with overclocking, correct? (Which I've never done, it actually makes me nervous)
Reply
#4
That cpu probably isn't the problem. Also the only overclocking method for that chip is BCLK ocing which is ddangerous and not recommended.

My advice is to mess with some speedhacks.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
FIXED IT! Enabling Vsync fixed it. I don't know why. I usually have to enable Vsync on most PC games because of screen tearing, but I wasn't getting any screen tearing with PCSX2 so I didn't bother to try it. But now with that setting on, everything runs incredibly smooth with maxed out enhancements (except for some hiccups when switching between menus on Frequency). It even fixed the slowing down/speeding up of the music on Tony Hawk 3.
Reply
#6
That's weird. I don't get why vsync would fix slowdowns. Maybe I should try it sometime.
Reply
#7
(07-23-2014, 06:31 PM)BlackTelomeres Wrote: That's weird. I don't get why vsync would fix slowdowns. Maybe I should try it sometime.

It dont , if you your in windows 7 and dont have desktop composition disabled vsync is already applied which why there was no tearing to begin with cause, GSDX/PCSX2 uses windowed (fullscreen)

Enabled vsync in pcsx2 in said scenario tend to be hit to performance.

It has to be something else he did cause Vsync dont work like that
Reply
#8
Vsync was exactly what it was. Just now I tested it again by unchecking Vsync, the lag came back. Checking the box again made it go away. And it didn't make the lag better, it made it non-existent. I used PCSX2 for two hours straight last night and without a single hiccup along the way. It was beautiful.

That's with windowed and full-screen, by the way. They behave exactly the same when I'm getting lag, which makes Vsync even less likely to be the fix, but it fixed it.

Not even the MTU hack made a difference, the lag is still there without Vsync turned on. I ultimately left MTU off since I have a game or two that won't boot with it left on.
Reply




Users browsing this thread: 1 Guest(s)