Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Game Speed too fast?!
#1
I'm trying to play Kingdom Hearts and I finally got it to work after multiple issues and trying several times. FINALLY. But when it runs, it's too fast, causing the sound to sputter. I can deal with this if I have to but I'd really prefer to play with the normal settings. The colors are kinda odd too now that I think about it.

Any help would be greatly appreciated!

Thanks!


Sponsored links

#2
Try pressing tab. You probably disabled the framelimiter from the GS configuration settings. What do you mean odd colors?
Edit: Whoops don't know the status of the game on the Mac port Wacko
[Image: newsig.jpg]
#3
(11-05-2011, 10:25 AM)Bositman Wrote: Try pressing tab. You probably disabled the framelimiter from the GS configuration settings. What do you mean odd colors?
Edit: Whoops don't know the status of the game on the Mac port Wacko

Okay the tab thing worked. Thanks. That was good to know.

Um yea :\ I don't know why the colors are off. In the beginning, everything's pink when I know it should be blue. And then it shows Sora's skin as green. That's definitely not right.

EDIT: Apparently it's just like that during the intro video. Once the game starts it's back to normal. But I still have no sound and I've tried using both SPU2null 0.80 and PEOpS SPU2 SDL 1.9.0. The second one used to work but it doesn't seem to want to now.

Here's my code if that helps at all? I don't know where/how to find the status of the game port.

PHP Code:
(<unknown>:1559): Gtk-WARNING **: Attempting to read the recently used resources file at `/Users/mccoyw/.recently-used.xbel', but the parser failed: Unexpected attribute 'modified' for element 'application'.

(<unknown>:1559): GLib-CRITICAL **: g_bookmark_file_get_size: assertion 
`bookmark != NULL' failed
ZZogl: Disabling MRT depth writing
ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.2
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-lFoeRU/org.x:0".
ZZogl: XF86VidModeExtension-Version 0.48681696
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-lFoeRU/org.x:0".
ZZogl: Failed to start fullscreen. If you received the 
"XFree86-VidModeExtension" extension is missing, add
Load "extmod"
to your X configuration file (under the Module Section)
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 8192 for Tex_2d and 8192 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Creating effects
ZZogl: Creating extra effects
ZZogl: using full shaders
ZZogl: initialization successful
ZZogl: Disabling MRT depth writing
ZeroGS: dummy transfer
ZeroGS: dummy transfer
ZZogl: Disabling MRT depth writing
ZZogl: Failed to create bitmask texture   ZZogl: Invalid unpack type
ZZogl: render target null, no constraints. Ignoring
ZZogl: Failed to create bitmask texture     ZZogl: Invalid unpack type
ZZogl: Invalid unpack type
ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type
ZZogl: Failed to create bitmask texture ZZogl: Invalid unpack type 

Thanks for the quick response by the way!
#4
MEssed up colours are due to using an older verson of the video plugin.
#5
How would I go about changing that exactly? Is there a recommended one to use? I don't even know where to go to see which one I have.

Also, sorry to bring up another problem but I came across another. The game seems to freeze less than a minute into the game. I can't even choose my weapon before it locks up. Is this a common KH problem? I'm thinking it could just be the iso.
#6
http://pcsx2mac.net/downloads/

download this

"GS plugins

ZZOglPG 0.1.0 – release version of ZZOgl-pg plugin(r3536 of official svn). It’s neccessary to enable “No logariphmic Z” option to fix the missing textures issue."

and the tutorial is here

http://www.youtube.com/watch?v=YZNE-izx5yU
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

#7
I tried the GS Plugin download and it didn't do anything for my pcsx2. I dont see the option there. I'll try it again tomorrow. I could be doing something stupid and catch it later.
#8
(11-07-2011, 10:06 AM)WingsLikeEagles Wrote: I tried the GS Plugin download and it didn't do anything for my pcsx2. I dont see the option there. I'll try it again tomorrow. I could be doing something stupid and catch it later.

Wrong, download this one instead
ZZOgl 0.21.204

The one that the other dude posted is old.
And here is how to install it manually:

1. First download the plugin
2. Open up the downloaded .DMG file
3. When extracted, it should open up a blank windows, containing nothing but a ZZOgl.0.21.204.app-file, right click on it and select "Show Package Contents"
4. Open the "Contents"-folder, then open the "Resources"-folder
5. In there you should see a file named "libZeroGSoglr.0.21.204.so.dylib", right click on it and press "Copy "libZeroGSoglr.0.21.204.so.dylib"".
6. Find you "PCSX2.app"-file, usually in the "Applications"-folder
7. Right-click on file, select "Show Package contents"
8. Open the "Contents"-folder, then open the "Resources"-folder, then the "pcsx2"-folder and then the "plugins"-folder
9. Right-click on an empty space in the plugins folder and select "Paste Item"
Close all opened folders and open PCSX2

Side-note:
You may want to install the portaudio and the ZeroSPU2 0.4.6 sound plugin
"Eventually you too will hear it, The Last Melody"
#9
(11-07-2011, 12:53 PM)Kaze Wrote: Wrong, download this one instead
ZZOgl 0.21.204

The one that the other dude posted is old.

Nah dude, the one you posted is old. Sure, the numbers in zzogl 0.21.204 are higher than zzoglPG 0.1.0, but they are totally different plugins, not different versions of the same plugin. ZzoglPG 0.1.0 allows for no log z, which helps the textures in games like KH and FF.

Not to say 0.21.204 might be better in some cases, but I''m pretty sure it's not in most.
13" MacBook Pro (March 2011)
Display: 1280x800
CPU: Intel Core i5 2.3 GHz w/ 2.9 GHz Turbo Boost
Memory: 4 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 384 MB
Software: Mac OS X Lion 10.7.3

#10
I'm going to try both anyways. The second one didn't fix anything that I was able to notice yet. But thanks for the step by step instructions! That helped.

EDIT: I must be doing something wrong cause none of these are working for me. And the sound went from choppy to nothing when I tried the ZeroSPU2 0.4.6 plugin....
I'm sorry I'm making this more complicated than it should be. I appreciate all the help you guys are giving me.

EDIT: Oh! The texture thing did work! Sorry I didn't get past the intro vid last time. My apologies.




Users browsing this thread: 1 Guest(s)