Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Game language problems!
#1
I have downloaded the beta version of pcsx2 (version 0.9.7.3113 May 29 2010) and I did a iso of 3 of dvd games (all originals for ps2, pal version!!): Final Fantasy X-2, Guitar Hero 3: legends of rock and God of War.
I knew that gh3 had no full-compatibility so i tried ffx-2; graphics and sounds are ok, but even if i set my bios language in italian, the game (pal version so multilanguage) is in english...i thought "not a big problem, it s english!"
I tried gow...after intro videos...all the game is in german...."that's a problem!"....
I started gh3...same problem..it s in german!
I've read all over the net that the problem is "yeah u set bios in italian, the game will be in italian": not at all!
I run pcsx2 as adminstrators (i have windows 7 home premium 64bit)....
so my question is: how can i change language????run-->execute works only on 0.9.6 version (and it still has problems of language!) and all games i tried has no "change language" option....please help me with suggestions and answers...
thanks
p.s. sorry for my bad english xD
Reply

Sponsored links

#2
Select "No Disc" from your CDVD menu. Boot Full. That'll get you into your bios menus.

Note that you can also safely swap a game into the CDVD from the BIOS too, if you want. Just select re-select the Iso source form the CDVD menu from the BIOS and it'll act just like your real PS2: boots the game. Smile
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#3
(07-29-2010, 02:57 PM)Air Wrote: Select "No Disc" from your CDVD menu. Boot Full. That'll get you into your bios menus.

Note that you can also safely swap a game into the CDVD from the BIOS too, if you want. Just select re-select the Iso source form the CDVD menu from the BIOS and it'll act just like your real PS2: boots the game. Smile

ok...i did...i ve always tried with fast boot..maybe that was the problem...if the problem is solved for gh3...for ffx-2 is not!
My friend (owner of ffx-2) said that menus and subtitles are multilanguage so, in our case, italian..but even with this procedure (boot full etc) it remains in english.....i don't know what to do, maybe i m so blind to see something wrong Smile but i think it s strange that with this procedure gh3 is in italian and ffx-2 isn't!
hope to have other information Smile
Reply




Users browsing this thread: 1 Guest(s)