Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Game play is very slow
#1
Hiya ppl this forum has really helped me in fixing issues regarding PCSX2.After fixing everything i started playing Smack down 2 but the game play is very very slow.I have the following configuration.

Processor: AMD Phenom™ II X4 945 Processor, MMX, 3DNow (4 CPUs), ~3.0GHz
Memory: 3326MB RAM
Page File: 954MB used, 4250MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode


Also FPS while playing is between 24-26 and Limiter="Normal".

PS Note:No external graphics card in my PC
Reply

Sponsored links

#2
Reports tell this game is hard on the machine. So it's possible the game not running at full speed, mattering not which hacks are applied.

Still your best bet is tinkering with the speedhacks to get the best possible performance before things breaking badly.

As first approach try setting on all the recommended speed hacks and move EE cyclerate and VU Cycle Stealing a notch to the right.

If not enough, move VU one notch more, play for a while, if not enough yet, move EE cyclerate one more notch..

You got the idea.
Imagination is where we are truly real
Reply
#3
Buddy here is the screen shot of my setting please check out whether it is correct or not


please click this link for speedhacks settings


please click this link for VU settings
Reply
#4
The sliders are at the extreme, it can cause sound and lag issues in almost all games. try reducing them a bit.

Try playing with the frameskip.

The values seen at the EE and GS percentage at the title bar, look at them in windowed mode, can give a reasonable idea where the bottleneck is.

The CPU is good enough for many games but the GPU is not, so will be GS the main suspect, it will be near 100% meaning the machine is already saturated. The onboard video card hardly can deal with anything more than the native resolution, set it on the GSDX plugin.

Less GPU intensive games will run smoother on your machine, all those with heavy 3D graphics will be too much for it, I'm afraid. Beyond certain point no software tweak will help anymore, only hardware upgrade will do the trick.
Imagination is where we are truly real
Reply
#5
hey buddy thanks for helping me but to be frank i don understand technically what you speak since i am an amateur.....here is the real time screen shot that have taken and please suggest any changes that can be done to speed up the game please help me out buddy


please click this to view screenshot




check out the values in the title bar
Reply
#6
All mine previous suppositions were confirmed.

97 FPS is too high, it should be around 60 in NTSC games, still it's reported as slow... what means the speedhacks are too much for this game, you must bring them down a bit (VU and EE cycle thingies).

Keep the FPS under control letting NOT marked the "Disable framelimiting" under the GS tab.

Now observe the GS value near 100%, it's the symptom your video card can't spill enough juice to keep the game at full speed.

Let's try to put it as a cookbook recipe

1- Begin removing all the speedhacks and make sure the GSDX plugin is running at native resolution.

play for a while and verify the FPS, the goal is have it around 60 (supposing it is a NTSC game). if it is above, you forgot the above advice about the frame limiting.

2- Your problem is not CPU, so the next step is trying to get the most juice we can under the GPU limitation...
So, try the game in "software mode", yes, your video card is small help, let have the CPU doing the work.

3- In software mode set the number of threads to 3.

try the game and report, if possible with screenshot or just tell us the FPS value and EE and GS percentage.

PS: with all the speedhacks off it's to be expected the FPS is low, but let's us treat the problem step by step.
Imagination is where we are truly real
Reply
#7
kbjan26, what's your gpu or graphics card model?
Reply
#8
I do not have external graphic card buddy.....

@nosisab Ken Keleh

i did all the changes what u mentioned in the receipe and have pasted the link for screenshot.The game is still f****g slow buddy.Is it because i don have an external graphics card??? please help me out i badly wanna play


please click here to view screen shot
Reply
#9
There's no need to be rude, people are only trying to help.

Have you tried GSDX in software mode? It is most definately being GPU limited
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
i aint rude at all...apologies....but damn i am unable to play it in a usual manner....yeah i am playing but setting the plugin to software mode only
Reply




Users browsing this thread: 1 Guest(s)