Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games are slow, need help (fps from 60 down to 30)
#1
Hi, first of all I'm new here and new to these PCSX2 emulators! I own a PS2 which I modded to play imported games from USA and Japan! But ever since I got a "LG 47 LED Full HD Tv with 400Hz True Motion" my games have been more pixelated than before and I heard of this emulator for pc's and learned that I can also make the games look even better than the originals on the PS2!

So I downloaded the emulator and ripped my game with Img Burn and booted up and fixed the settings and started to play the game which is .Hack// G.U Vol 1. At first I got 60 fps, but then my game slowed down to 30 and even 20 fps!

My computer has these;
Quote:¤ Windows 7 32/64
¤ Intel Core i7-2630QM 2GHz with Turbo Boost up to 2,9GHz
¤ NVIDIA GeForce GT 540M, up to 3765 MB TurboCache
¤ 4 GB DDR3 Memory

¤ This is when I use the "Native" Original PS2 Resolution
LINK: Original PS2 Resolution

¤ And this is when I scale it up to maximum and it dosen't affect the speed(fps) of the game
LINK: Maximum Resolution

But the game still lags alot and makes it very hard to play it Sad it gets really slooow sometimes that it seems like as it freezes..
-----

I would appreciate it if anyone could help me with this, is my computer not good enough or am I missing something? :/ If I can get this to work perfectly by your help I will connect my computer to my TV and play it there which will look 10times better than playing it with my PS2 Smile

Thanks in advance Smile

EDIT: By the way how do I edit my "Signature" I can't find it in "User CP"
[Image: 6yo6so.png]
Noctis Lucis Caelum
Reply

Sponsored links

#2
pcsx2 settings?

edit sig: http://forums.pcsx2.net/usercp.php?action=editsig
Reply
#3
did you set your power plan to high performance ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
(12-08-2012, 08:23 AM)Saiki Wrote: pcsx2 settings?

edit sig: http://forums.pcsx2.net/usercp.php?action=editsig
signature: I see, so I need 3 post before I can add signature, thank you Tongue

Here are my settings if it is those you asked for Smile
PCSX2 Settings
PCSX2 Core Settings GS

I also tried it with 2x Native and 3x Native "D3D Internal Resolution"
-----

(12-08-2012, 08:32 AM)jesalvein Wrote: did you set your power plan to high performance ?

You mean from my graphic card? from NVIDIA settings or the whole computer? Smile As I said, I'm kinda new to all these things Smile
[Image: 6yo6so.png]
Noctis Lucis Caelum
Reply
#5
(12-08-2012, 03:28 PM)LegendarySaiyan Wrote: You mean from my graphic card? from NVIDIA settings or the whole computer? Smile As I said, I'm kinda new to all these things Smile

[Image: perfnd.jpg]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
Just as a possibility, if the FPS falls to exact 30, it may be caused for Vsync (vertical synchronism) active, probably at your videocard control panel.

Anyway it would mean the FPS is bellow the 60...
Imagination is where we are truly real
Reply
#7
(12-08-2012, 03:38 PM)jesalvein Wrote: [Image: perfnd.jpg]

Didn't help so much Sad Thanks anyway Smile

EDIT:
(12-08-2012, 04:29 PM)nosisab Ken Keleh Wrote: Just as a possibility, if the FPS falls to exact 30, it may be caused for Vsync (vertical synchronism) active, probably at your videocard control panel.

Anyway it would mean the FPS is bellow the 60...
Hmm I tried both turned on and off, but didn't affect it :/
Though when I checked "Disable Frame Limit" from the GS Core Settings I suddenly got 200fps on the game menu before I loaded my game, then it fell down to 40fps and 20fps!
[Image: 6yo6so.png]
Noctis Lucis Caelum
Reply
#8
(12-08-2012, 04:30 PM)LegendarySaiyan Wrote: Didn't help so much Sad Thanks anyway Smile

EDIT:
Hmm I tried both turned on and off, but didn't affect it :/
Though when I checked "Disable Frame Limit" from the GS Core Settings I suddenly got 200fps on the game menu before I loaded my game, then it fell down to 40fps and 20fps!

Do not use the Menu as base, it is only 2D and easy on the emulator, when the game kicks is when the CPU is put to scream. That's right, most of PS2 graphics must be "translated" from the VUs (PS2 vector unities) before going to GS. Besides is when the game starts really producing a lot of differentiate code flux to be "translated" from the EE (the PS2 CPU core)... recompiled is the tech term but in the end is a translation from PS2 code to a format PC can execute, hence emulation is so hard on the emulating machine and PS2 is specially hard compared with previous generation consoles.

So, when you get actually into the game the stress on the CPU is multiplied many times.
Imagination is where we are truly real
Reply
#9
(12-08-2012, 04:52 PM)nosisab Ken Keleh Wrote: Do not use the Menu as base, it is only 2D and easy on the emulator, when the game kicks is when the CPU is put to scream. That's right, most of PS2 graphics must be "translated" from the VUs (PS2 vector unities) before going to GS.

So, when you get actually into the game the stress on the CPU is multiplied many times.

I don't use the game menu as a base Wink I always enter the game and try to warp to a bigger location and then it starts slowing down from 65fps to 20fps..

So I am clueless and don't know how to fix this Sad btw I use "PCSX2-r5350" forgot to mention that in my first post Smile
[Image: 6yo6so.png]
Noctis Lucis Caelum
Reply
#10
(12-08-2012, 03:28 PM)LegendarySaiyan Wrote: Here are my settings if it is those you asked for Smile
PCSX2 Settings
PCSX2 Core Settings GS

that's graphics, not pcsx2 settings. pcsx2_vm.ini is preferable, it says everything
Reply




Users browsing this thread: 1 Guest(s)