Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games ran good speed prior to gfx card update. Slower since (in .hack GU 3)
#1
Hey all

My first new post here in a fair while.

Anyways I currently have the following PC setup:

Intel Core i7 920 2.67GHZ
3GB Ram

And prior to a few days ago I was using a:

Radeon HD 5670

And most games were running pretty well. Not all, but enough. In particular I've been playing through the .hack series (first the 5 SIGN games then I moved onto the GU series) and am currently playing .hack GU part 3, which was running at 50-60 fps for the most part.

Then on Saturday I upgraded to a Radeon HD 7950 (in order to play PC games in better settings mostly) and whilst I have noticed a significant improvement in the PC games I play, the same cannot be said of PCSX2. Speeds in .hack GU 3 have dropped quite sharply to 25-60 in town and dungeon locations of the game.

Note that I am using rev 5269 of the emulator and the latest version of GSDX (rev 5268).

This is the first time for me where a PC upgrade has resulted in worser speeds in a program than before. Any help would be most welcome.

I've tried reverting to earlier revisions to test if it was something to do with the latest revision but encountered the same issues. I'm playing with speed hacks (INTC spin, Wait Loop Detection, mVU Flag hack and the MTVU hack) on just as I did prior to the upgrade.

On switching gfx cards I uninstalled all nvidia drivers on my PC which caused me some issues when attempting to compile the latest rev but I reinstalled the cg toolkit.

Is there anything I can do besides switching back to the inferior gfx card or am I pretty much screwed?
Old habits die hard - System Shock
Reply

Sponsored links

#2
did you check your graphic card's frequency while running pcsx2?
assume that all emulator settings are same, it seems to me like you gpu not running in 3d mode,just wild guess
Reply
#3
How do I check that? I went into the graphics card settings whilst the emulator was running and didn't see anything about 3D mode. Just settings about gpu clock speeds etc. I tried changing what I could (standard 3D settings) over to best performance and tried settings the gpu clock speed at max and no change.

One thing to note was that with the previous gfx card I was using direct x 10, and with the new one dx11.
Old habits die hard - System Shock
Reply
#4
(06-05-2012, 05:36 PM)icemann Wrote: ... and tried settings the gpu clock speed at max and no change. ...

Ohmy

You, uhhh--
You know what you're doin' there, pal...????
Reply
#5
(06-05-2012, 06:04 PM)Rezard Wrote: Ohmy

You, uhhh--
You know what you're doin' there, pal...????

inb4blownupgpu
Reply
#6
Well he's offline for a reason;P heheh, but probably it would just simply reset after crash without any cool looking explosions we all imagine, besides it wouldn't just start to constantly run at max when set like that knowing amd;].

@op just use GPU-Z to check your gpu clocks while using pcsx2, if your gpu core is at 300mhz it's at idle state, if it's at 500mhz or soo it's probably thinking you're just watching hardware accelerated movies(any flash application/web page can cause that), one way or another most likely your gpu doesn't give you it's power assuming you don't need it. Generally anything below it should be ~ 900-1000+ mhz means your gpu is working in some power saving state.
If that's the case then you'll probably have to force higher clocks, dunno maybe MSI Afterburner would work for that, possibly even running pc game in the back would work too;3. The new amd gpu's are doing everything to minimize power consumption, AMD is proud of it, and guess it is cool when it's working it's just the existence of applications like pcsx2 are widely ignored and the drivers probably doesn't consider it as heavy couse it usually uses dx in different ways than native pc games for which it's optimized.(just my guess, can as well say "AMD drivers sucks" before any Nvidia fanboy does it;])
Reply
#7
Lol no explosions happened. I only had it on Max briefly, purely to see if it made a difference which it didn't. The overclocking according to the settings only comes into affect when "the gpu is running in high performance mode".

Here's some GPU stats according to the Catalyst control center:

Prior to running the emulator the GPU clock was on 300 MHZ and moved up to 900 MHZ whilst it was running.

I tried running a game in the background (Dead Island) and it didn't go above 900MHZ still. I don't get how an older graphics card could run better. I understand that as you say its likely assuming I'm watching a movie or something. Very annoying.
Old habits die hard - System Shock
Reply
#8
A brief moment is all it can take, too. ;P

I knew a guy--
Let's just say he did what you did...
Reply
#9
I'll be the first to admit that I have no idea what I'm doing with the radeon settings. I just want things running as they did where the emulator is concerned, rather than bad frame rates like I was getting many many years ago when this emulator didn't have the dual core support etc.

Runs perfectly fine on the PC games end. No tinkering required. It's all just very frustrating to go from 45-60 down to 25 or lower.
Old habits die hard - System Shock
Reply
#10
(06-05-2012, 08:10 PM)icemann Wrote: Lol no explosions happened.


FFFFUUU-

Anyway don't mess with overclocking if you don't know much about it.
Reply




Users browsing this thread: 1 Guest(s)