Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games runs at either 50% or 100% randomly
#1
Hello All -

I just set up PCSX2 on my new laptop and am having a very strange issue. The majority of the time I start up a game, the game will run at exactly 50% speed (30FPS). Once it starts, it never wavers from exactly 50%. Not 49%, not 51%, always 50%. When it is running at 50% speed, no changes that I make impact the game speed whatsoever. I can run max settings, minimal settings, or anything in between and I get 50%. I know my PC is powerful enough to run this without issue because it also at times runs at 100%, and when I disable the frame limiter I can usually get about 120 FPS in game, so something is happening that is causing my PC performance to drop by 75%. I thought maybe I was accidentally running in slow-mo mode somehow, but I changed the slow-mo speed to 100% and it still happens sometimes. Any ideas what could be causing this?
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.
Thank You.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#3
(12-15-2016, 07:17 PM)lightningterror Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.
Thank You.

Windows 10, Nvidia 970M, Intel I7.

Newest Version.

Happens with all settings including default.

Happens with every game I have tried (Resident Evil 4, Persona 3, Persona 4Final Fantasy 10, Final Fantasy 12) from Iso
Reply
#4
Full specs of your i7 please , model number.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#5
Quick question: Have you set your Laptop to use the High Performance mode in Power Options?
If not, try that.
[Image: pe6swy-2.png]
Reply
#6
(12-15-2016, 09:11 PM)ShadedTear Wrote: Quick question: Have you set your Laptop to use the High Performance mode in Power Options?
If not, try that.

I thought I had, but on further inspection it was set on factory mode, so that might be it. I am thinking it is something along those lines, I.e. some kind of automatic setting change within my PC, rather than anything within PCSX2 since it happens independently of settings. I have had the 50% slowdown when the laptop is plugged in so I'm not sure if this was it, but I did change it to high performance. I'll let you know if I continue to experience the slowdown. Good idea either way!
Reply
#7
(12-15-2016, 08:13 PM)lightningterror Wrote: Full specs of your i7 please , model number.

I don't know if these are the full specs or not, but in control panel it says "Intel Core i7-6700HQ CPU @ 2.60 GHz."

Sorry if that's not enough, I am not as computer literate as I used to be. If it helps, this is my computer:

https://www.amazon.com/GL502VT-DS71-Gami...+rog+strix
Reply
#8
Quote:i7 6700HQ

That is what I needed. You pc should be able to run a lot of games at full speed. If changing the power plan didn't help then can you check your temps? Maybe your laptop is throttling down.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply




Users browsing this thread: 1 Guest(s)