Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games suddenly running at half the speed
#1
Okay, so I've been using pcsx2 to play DBZ Budokai 3 (that's the only game I play), and I've been running it smoothly at 60fps for ages. I stopped playing for a bit, but when I came back to play it, it slowed down to 30fps whenever I try to play. The only things I can think of that I have changed since I stopped playing was downloading and installing some steam games, but that's about it.

Does anyone know what I can do to fix this problem?

Thanks
Reply

Sponsored links

#2
Check this screen: http://i.imgur.com/8RblK.png - What does yours say?
My YouTube (Kingdom Hearts II: Final Mix FULLY TRANSLATED!): http://www.youtube.com/tyestor
MyAnimeList: http://www.myanimelist.net/profile/tyestor
Last.fm: http://www.last.fm/user/tyestor
My PCSX2 settings: http://i.imgur.com/za8rp0n.png
My PC Specs: http://i.imgur.com/5bgg9P3.png
Current PCSX2 revision: r5932
Reply
#3
mine is the same as that one
Reply
#4
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Intel i7 2670QM 2.2GHz
nVIDIA GeForce GT 540M
8GB RAM
Windows 7 Home Premium 64 bit

I'm using 1.0.0 and playing Dragonball Z Budokai 3 from an ISO and I'm using 2x scaling and I think I've changed the resolution to fit my screen, but that is all.
Reply
#6
Set your power plan to high performance.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
its either the following:


1- your vsync is messing your fps up (turn it either off or adaptive in nvidia's control panel and unckeck in pcsx2 itself, which is unchecked by default)
2- your laptop is not on high performance (control panel >> system and security >> power plan)
3- the processor is getting to hot while playing the game and it lowering its clockspeeds to compensate, hence the speed drop
4- be sure you dont have any fps limiting programs on (nvidia inspector for example has an option for that)
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#8
I've done what you guys have saidd and nothing has worked. I even tries changing it's settings in the nvidia control panel so it uses the highest performance, but that didn't work. I also niticed that it on the top of the window where it has all the details (like framerate) it says "limiter: normal". I don't know what that means.
Theonly conclusion that I can come to is that it is overheating.
Reply
#9
(01-18-2013, 03:20 PM)ButtSwag Wrote: I've done what you guys have saidd and nothing has worked. I even tries changing it's settings in the nvidia control panel so it uses the highest performance, but that didn't work. I also niticed that it on the top of the window where it has all the details (like framerate) it says "limiter: normal". I don't know what that means.
Theonly conclusion that I can come to is that it is overheating.

high perfomance isnt in the nvidia control panel but in configuation screen of windows itself.

(start>> control panel >> system and securety >> powerplan)


try cleaning the laptop that could decrease heat because dust can collect in there and prevent the fans from spining at maximum speed.
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#10
Still looks like Vsync or power option problem like already pointed. Let's just add that "adaptive" in the Nvidia control panel may confuse the emulator, add an entry to PCSX2 at "the program settings" and change it to "off" there instead the global which you may want to let in adaptive.

Second point is about the power performance, was not that in the nvidia control panel that was mentioned but that one in the Windows control panel. It's an already known issue it fails on PCSX2 with Intel CPUs, mainly in laptops where that power saving feature is more aggressive.

You may need to force "Show Additional plans" to be able to see the "performance mode" there. And yes, Microsoft still treats the users as stupids who need to be protected against themselves and then love to "hide" things.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)