Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting it to work
#1
Hello, first post. I recently managed to get PCSX to run on my macbook, and am now curious as to whether I can manage to get PCSX2 running. So far I can't.

I followed the guide here and I get the little blue screen, but from there I try to run the BIOS and in X11 it says:


Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 10653 Bus error ./pcsx2

On a sidenote, I've read things about moving the BIOS to a subfolder of the app, but in my Finder pcsx2 has no subfolders to put anything in to. Maybe I'm being very dense. In any case, I went to the Config in PCSX2 and set the BIOS folder as the one on my desktop where I've got the BIOS.

I looked around but couldn't find anyone with the same error message so I thought I'd try my luck on the forum. Thanks for any help you can offer. Have a nice evening!

Sponsored links

#2
post your entire bash, that doesnt tell me much other than im pretty sure 0xea000000 means it doesnt have or can't find the bios.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

#3
(08-25-2011, 06:16 AM)mubbsy Wrote: post your entire bash, that doesnt tell me much other than im pretty sure 0xea000000 means it doesnt have or can't find the bios.

Code:
F1 - save state
        (Shift +) F2 - cycle states
        F3 - load state
PCSX2 beta (r2620254) - compiled on Jan 27 2011
Savestate version: 8b410001
EE pc offset: 0x2a8, IOP pc offset: 0x208
x86Init:
Features:
Loading plugins...
        Loading GS...
        Loading PAD1...
        Loading PAD2...
        Loading SPU2...
        Loading CDVD...
        Loading DEV9...
        Loading USB...
        Loading FW...
Plugins loaded successfully.
Resetting...
Ready
Bios Version 2.0
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Initializing plugins...
ZZogl-PG: Calling GSinit.
ZZogl-PG: GSinit finished.
Plugins initialized successfully.
Opening Plugins...
Notice: GS Plugin does not implement GSsetFrameLimit.
MTGS > Thread Started, Opening GS Plugin...
ZZogl-PG: Calling GSopen.
ZZogl-PG: Creating ZZOgl window.
Plugins opened successfully.
GetElfName: SYSTEM.CNF not found; invalid cd image or no disc present.
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
ZZogl-PG:  Got Doublebuffered Visual!
ZZogl-PG:  glX-Version 1.2
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-RMSCn4/org.x:0".
ZZogl-PG:  Depth 24
ZZogl-PG:  You have Direct Rendering!
ZZogl-PG:  *********
ZZogl: OGL WARNING: multiple render targets not supported, some effects might look bad
ZZogl: *********
ZZogl-PG:  Using multitexturing.
ZZogl-PG:  Maximum texture size is 2048 for Tex_2d and 2048 for Tex_NV.
ZZogl-PG: Disabling MRT depth writing.
Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2: 12847 Bus error               ./pcsx2

Here's some information about my laptop too. I'm using Snow Leopard:

Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 1 GB
Bus Speed: 667 MHz
#4
I think this could be a problem similar to the one mucho chris is having. Here's the terminal message I keep getting…

F1 - save state
(Shift +) F2 - cycle states
F3 - load state
PCSX2 beta (r2578822) - compiled on Jun 30 2012
Savestate version: 8b410001
EE pc offset: 0x2a8, IOP pc offset: 0x208
x86Init:
Features:
Loading plugins...
Loading GS...
Loading PAD1...
Loading PAD2...
Loading SPU2...
Loading CDVD...
Loading DEV9...
Loading USB...
Loading FW...
Plugins loaded successfully.
Could not open '/Users/useruser/Desktop/PCSX2' directory

(<unknown>:2469): Gtk-WARNING **: Attempting to read the recently used resources file at `/Users/useruser/.recently-used.xbel', but the parser failed: Unexpected attribute 'modified' for element 'application'.

(<unknown>:2469): GLib-CRITICAL **: g_bookmark_file_get_size: assertion `bookmark != NULL' failed
Bios Version 1.60
Bios Warning > rom1 not found.
Bios Warning > rom2 not found.
Bios Warning > erom not found.
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Loading plugins...
Loading GS...
Loading PAD1...
Loading PAD2...
Loading SPU2...
Loading CDVD...
Loading DEV9...
Loading USB...
Loading FW...
Plugins loaded successfully.
Initializing plugins...
ZZogl-PG: Calling GSinit.
ZZogl-PG: GSinit finished.
Plugins initialized successfully.
Opening Plugins...
Notice: GS Plugin does not implement GSsetFrameLimit.
MTGS > Thread Started, Opening GS Plugin...
ZZogl-PG: Calling GSopen.
ZZogl-PG: Creating ZZOgl window.
ZZogl-PG: Got Doublebuffered Visual!
ZZogl-PG: glX-Version 1.4
Xlib: extension "XFree86-VidModeExtension" missing on display "/tmp/launch-0fBKKf/org.macosforge.xquartz:0".
ZZogl-PG: Depth 24
ZZogl-PG: You have Direct Rendering!
ZZogl-PG: *********
ZZogl: OGL WARNING: multiple render targets not supported, some effects might look bad
ZZogl: *********
ZZogl-PG: Using multitexturing.
ZZogl-PG: Maximum texture size is 2048 for Tex_2d and 2048 for Tex_NV.
ZZogl-PG: Disabling MRT depth writing.
ZZogl-PG: You've manually enabled these hacks:
ZZogl-PG: 'No logz' hack enabled.
Offset 0xea000000 invalid. Legit SIGSEGV. Aborting.
Bus error: 10
logout

[Process completed]




Users browsing this thread: 1 Guest(s)