Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting low FPS for Kingdom Hearts 1
#1
I keep getting low FPS for Kingdom Hearts 1. I feel as if my computer should be capable of running close to full speed, but alas, that does not seem to be the case.

SPECS:
Windows 7 64-bit
Intel Core Duo 2 CPU 2.40GHz
6 GB RAM
NVIDIA GeForce 9600M GT ~3GB total memory

Plugins Used:
http://i56.tinypic.com/o69oc8.jpg

Graphic Plugin Settings:
http://i55.tinypic.com/29f8ppw.jpg

I usually get good FPS (50-55), but every other minute the game drops to around 30 FPS, the music gets real slow, and the game gets real slow, then it tries to catch up on itself and goes really fast. I would be thankful to just have 50 FPS consistently, but I am wondering if there is something I am not seeing that I need to check or turn on. Tried Speedhacks and they didn't seem to work.

I also notice that my EE % is rather high. Is there a way to lower it? I think that is what may be giving me my low FPS issue.
Reply

Sponsored links

#2
Sounds like some kind of throttling, try settings the power profile in control panel to high performance.

You forgot to post your PCSX2 settings.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Trying using speed hacks. The game should run fine with all of them applied. I ran the game with 0.9.6 with all three speed hacks and 2x cycling rate on a pc with 1.86ghz core 2duo and got about 50-60fps with the occasional 45fps. Also try lowering settings on the audio. I.e, turning off mixing effects. I would keep time stretching turned on. By default I think all of the cpu settings are set, but make sure you have multithreadGS turned on. Maybe try setting the frame skip higher.
[Image: signature.jpg]
Reply
#4
Does running background programs affect your performance significantly? Sometimes I have µTorrent running in the background, and that may be the cause of some of my troubles.

I'm not sure what you mean by PCSX2 settings, but I have microVU on and clamping mode set to normal (though I don't know what any of that means) and I did activate VU Cycle Stealing to 1. getting more consistent frame rates, but still have some minor issues. A lot better though and definitely playable!
Reply
#5
The only time I run into other programs slowing me down is when I'm uninstalling something. But I've also got a faster machine. However, I would just play around with settings.
[Image: signature.jpg]
Reply
#6
I'm using 0.9.7, is there a way to tell if MTGS is on? or is it always on? The only option I see is synced MTGS, but that doesn't seem to be the option to turn it on.
Reply
#7
Well I'm using .9.6 So I'm not sure where the setting is or how to turn it on. But what it does is it turns on Mult-Core Processing. I'll install the newest one to help you out. I'll report back shortly.

EDIT: So I was unable to find anything. I'm sorry but I can't help you with this. Using 9.7 I get the game 100%, however I have a more powerful machine. Still just try experimenting with the sound and speed hacks.
[Image: signature.jpg]
Reply
#8
MTGS is always enabled in the 0.9.7 Beta.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
having the same issue. any updates?

I am applying some of the speedhacks with no results
Reply




Users browsing this thread: 1 Guest(s)