Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Getting low fps on good gaming PC
#1
I'm new to PCX2 and i'm using the default setting for version 1.0.0. Anyway, I can get the games to work like FFX and Kingdom hearts but I can only get around 40 fps, so the game feel laggy. Is there anyway to increase my FPS because I see people online playing in 60 fps and there Computers are worst then mine.
Reply

Sponsored links

#2
There's definitely an issue there. I'm on a laptop and I can run it at 60FPS 3x rez. What are your settings?
Reply
#3
(05-19-2013, 06:33 AM)swampertkamm85 Wrote: There's definitely an issue there. I'm on a laptop and I can run it at 60FPS 3x rez. What are your settings?
Its on Default, When I installed PCSX2 I left everything the way it is. Im currently playing the games on ISO. But still getting 40 fps.
Reply
#4
(05-19-2013, 06:40 AM)mattx019 Wrote: Its on Default, When I installed PCSX2 I left everything the way it is. Im currently playing the games on ISO. But still getting 40 fps.

That'll do it. Here, this is from the wiki:

EE CycleRate (3): noticeable speedup, setting it to 3 causes no issues.
INTC Sync Hack: small if any speedup, no issues.
Idle Loop Fast Forward: noticeable speedup, no issues.
mVU Flag Hack: Good speed up, no issues.
mVU Block Hack: Good Speed up, no issues
MTVU: Noticeable speedup with 4+ core CPU's.

Basically, enable all of those.
Reply
#5
Have you tried enabling speed hacks? You can also try setting the number of threads to 3 as well. This seems to help a lot of people.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#6
(05-19-2013, 06:41 AM)swampertkamm85 Wrote: That'll do it. Here, this is from the wiki:

EE CycleRate (3): noticeable speedup, setting it to 3 causes no issues.
INTC Sync Hack: small if any speedup, no issues.
Idle Loop Fast Forward: noticeable speedup, no issues.
mVU Flag Hack: Good speed up, no issues.
mVU Block Hack: Good Speed up, no issues
MTVU: Noticeable speedup with 4+ core CPU's.

Basically, enable all of those.

Yeah.... what? His PC is such that he won't need speed hacks for this game, and even then EE cycle rate set to 3 can cause audio desyncs in cutscenes so I wouldn't recommend it.

With a PC like his he should never use more than the ones marked "recommended" and even then it'd likely to be overkill in quite a few games.



Now back to actually trying to figure out what the heck is causing his slowdowns. Check the top of the game window, there should be 2 (or 3 if you enabled the MTVU hack) things listed, EE and GS (and VU). What are their percentages when the game is slowed down?
[Image: 2748844.png]
Reply
#7
EE 1% to 6% it keeps changing.
GS: 0% to 5% keeps changing.
UI: 0% to 1%
State 0
Limiter: Normal
Fps: 40
Interlanced (Field) 512x448
GSdx
Reply
#8
(05-19-2013, 02:55 PM)mattx019 Wrote: EE 1% to 6% it keeps changing.
GS: 0% to 5% keeps changing.
UI: 0% to 1%
State 0
Limiter: Normal
Fps: 40
Interlanced (Field) 512x448
GSdx

Oh man, is the first time I look those numbers and really can't make much of them... the machine is not being taxed at all.

The only thing I can imagine is for some reason the frame limiter is set to less than 100%

To see it, go to GS config tab (under the Emulator's settings, not the GS plugin config). and make sure the Base Frame adjust is 100%
Imagination is where we are truly real
Reply
#9
May be you accidentally change limiter?
Reply
#10
(05-19-2013, 03:14 PM)nosisab Ken Keleh Wrote: Oh man, is the first time I look those numbers and really can't make much of them... the machine is not being taxed at all.

The only thing I can imagine is for some reason the frame limiter is set to less than 100%

To see it, go to GS config tab (under the Emulator's settings, not the GS plugin config). and make sure the Base Frame adjust is 100%
Just checked and its
Base Framerate Adjust: 100%
Slow Motion Adjust: 50%
Turbo Adjust: 200%
Reply




Users browsing this thread: 1 Guest(s)