Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Hand (PAL) Slow!
#1
Hey all, this is my first post on this forum.

So I'm having trouble getting God Hand to run too well on my PC with my preferences. I've tried fiddling with the settings and seems like at best I'll get around 70% speed.
I'm playing on 3x native res with the widescreen patch, other than that all the settings are vanilla. I've tried DX11, D9D and OpenGL - no distinct performance increase there with either of them. Oh and I'm running build 1.4.0.

My rig's got i5 3470, GTX 660 and 8GB ram, nothing impressive these days for sure but then there's videos like this - https://www.youtube.com/watch?v=k4uaqQ2O1q8 with the guy running the game on full speed at 1080p with a 60fps patch - and he's got quite a destitute setup with a HD 6310 which is a notebook GPU from 2013? Something seems to be off with my setup if this guy's computer outdoes mine by such a margin.

I've tried messing with the speedhack presets too but no dice :/

Any tips?
Reply

Sponsored links

#2
I don't know if it will make a huge difference, but I'd try newest git builds.

I play God Hand daily and I'm mostly running 100% speed with rare minor slowdowns. (with an FX-8300 @ 4.7GHz)
Hey,  I'm writing yet another PCSX2 frontend. Source code is being hosted at GitHub.
Reply
#3
I updated my video drivers and tried the latest git build but they were no help either.

Here's a cap of my gs plugin settings if that's useful at all. It seems that changing the native resolution doesn't effect the performance much.

[Image: 26c867a801.png]
Reply
#4
While you have a decent CPU, your GPU is very weak. You might need to invest in an upgrade. Or, at least only use default minimum settings. Don't set IR to 3x with that graphics card
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply
#5
The cpu and the gpu(it's similar to mine and the game works fine...I can't test again)are fine but I'm not sure it can handle 3x or above on the game.

For nvidia card,better use OpenGL and also,are you using some non default PCSX2 settings(check again,don't automatically say no)
Reply
#6
All the emulation settings except for GS where I have enabled widescreen and 1080p resolution are at their presets:

[Image: 174ab4e7f7.png]



[Image: 72164ad52e.png]

[Image: 18fa82b9cc.png]

[Image: 1b67917678.png]



[Image: 44b218fffc.png]
I tried OpenGL, D9D, DX11, all give me slow performance. Native still gives me a lot of slowdown. In contrast, increasing the internal resolution to 4x native doesn't seem to slow the game down any more than it already performs at.
Reply
#7
use mtvu speedhack
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
Quote:use mtvu speedhack


Still no help Wacko

By the way, I think the OpenGL actually makes the performance even worse for me.
Reply
#9
how much worse?

Did you try ticking "allow 8-bit textures" and unticking "large framebuffer"? You could also try enabling hw hacks then configuring that section to enable the "fast invalidation" hack, that may help speed slightly.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(01-25-2017, 11:44 PM)refraction Wrote: how much worse?

Did you try ticking "allow 8-bit textures" and unticking "large framebuffer"? You could also try enabling hw hacks then configuring that section to enable the "fast invalidation" hack, that may help speed slightly.

Hate to sound like I'm repeating myself, but I did not notice those tweaks improving the performance either.


Quote:how much worse?

Just a bit worse I guess? The window border info always seems to claim i'm running at full 50hz and 100% so its hard to say.

PS: The hw hack made the skybox flicker
Reply




Users browsing this thread: 1 Guest(s)