Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War 1 FPS drops
#1
This is my first ever thread in a forum so i know i'm going to miss something, so forgive me.
I'm trying to run GoW 1 on my rig and been getting pretty strange (at least for me) results. I'm playing a PAL version and the game usually goes from 50fps to 30 for no apparent reason, and aways in the same spots (i've tried to turn on and off the speed hacks, but nothing changes), slowing down movement. Is this reasonably for my pc?

Specs:
CPU: AMD FX 8320 eight core... (Not OC'd)
GPU: Geforce GTX 970
RAM: 8gb (DDR3)

Sory for the poor english and if this has been answeared over and over, i'm just not finding anything in my searches.
Reply

Sponsored links

#2
Thanks for making a new thread.

Anyways, Are you playing from a disc or ISO?
Can you post screenshots of all of your settings?
What version of PCSX2 are you using?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
-From an ISO
-Configs - Tell me if i missed something
-Version 1.2.1
Reply
#4
Try one of the git builds, use OpenGL and try with and with out MTVU

I not sure inst GOW series rather demanding on the cpu?
Reply
#5
not really, my old C2D managed to run it fine. you'd probably need the Opengl exclusive options to accurately reproduce some effects.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
Was VU cycle stealing needed for GOW? I played it as well on my C2D but I can not remember. I think I always used EE cycle rate hack instead.
Reply
#7
(11-18-2015, 05:06 PM)willkuer Wrote: Was VU cycle stealing needed for GOW? I played it as well on my C2D but I can not remember. I think I always used EE cycle rate hack instead.

I don't recall using VU cycle stealing, only an increment to the EE cycle rate and it ran pretty well at most of the scenes. I usually avoid VU cycle stealing. ( It screws most of the games speed a bit causing weird momentary lags and unusual skips )


Quote:I'm playing a PAL version and the game usually goes from 50fps to 30 for no apparent reason

some scenes are a bit demanding , most likely to be one of them when you get lowered to 30 fps. also enable MTVU hack at configuración de emulación, might help a bit. Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
OMG, i completely forgot i left everything in portuguese, sorry haha.
I really couldn't figure out how to use those GIT builds, but i tried with and withouth the MTVU and the result is pretty much the same.
It's funny that in moments like the first fight with Ares where there are thousands of people fighting on the ground and a giant god in front of me i have no FPS drops and while i'm looking at a ballista it drops so much.

Trying OpenGl hardware and software with MTVU on/off, just a sec.

Edit:
OpenGL (Hardware) with MTVU on seems to have done the trick. The game is much more stable at 60fps, but still at the parts i would usually go to 30 i can notice some stutter and something with the audio, and my EE goes up to 100% sometimes. Is this normal? The game is totally playable, i'm just curious, because it seems my luck is not too good with this CPU 
(just gave up Fallout 4 because of extreme FPS drops too).
Reply
#9
guys?
Reply
#10
max EE mean Cpu bottleneck last i checked just cause some parts of the game run full speed dont mean it dont have scenes are parts that are much more demanding
Reply




Users browsing this thread: 1 Guest(s)