Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War II capped at 30~50 fps
#1
Hi.
First things first, my specs:
i7-3630QM @ 2.4
HD Graphics 4000 + Geforce 740M
RAM 8GB
PSCX2 1.0.0 Default Build

So,
GoW 2 at 30 fps when surrounded by enemies
Can anyone help me configure the emulator to run Kratos smoothly?
I can run Tekken 5, FFX and XII at 60 fps.
Thanks.
Reply

Sponsored links

#2
Well, it's normal for the emulator to slow down when the GS is rendering too much especially with a demanding game like GoW.
List your emulator settings so we could see where to help you from there.
Reply
#3
I didn't change anything on the emulator. It's the 1.0.0 r5350.
Reply
#4
Try putting the bars in the Speedhack section in the Emulation Settings on 2 and 1 and enable MTVU.
If it gets too laggy at some point, try using native resolution in the GS settings until you're clear.
Reply
#5
You may set gsdx internal res to native ( your gpu is weak) and check your windows power plan is set to high performance too...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
Hi i'm also playing this game
yes this game have slowdowns when lts of enemies around you
Enable recommended speedhacks for this game & tick mtvu hack (Recommended if 3+ cores)

Tick native resolution if u can
but i'm playing on 2x native.
if u can live in slowdowns play in 2x
Reply
#7
Thanks everyone.
Now I can run GoW2 at 50fps contantly and feels like playing on a real playstation 2.
Maybe the frame rate is bugged or something lol.
Reply
#8
If it's never going above 50 you probably have the PAL version (which is limited to 50fps).
[Image: 2748844.png]
Reply
#9
Oh, yes it is.
Reply




Users browsing this thread: 1 Guest(s)