Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War Issues :<
#1
Hi, I'm entirely new to this forum so I don't expect you all to take me in so easily but I really don't have anywhere else to turn.

I went out today and purchased God Of War for PS2 at my local Gamestop and came home to try it out with and emulator. I own a PS3 but it's in my basement and, long story short: using it at night is impossible and that's really the only free time I get anymore.

Anyway, I put the disk in the computer and booted up the program which obviously didn't work, so I've been playing around with plugins and speedhacks and other little options for hours upon hours. After consuming my entire day with this, I decided that this forum would likely be the best place to ask for help concerning my problem.

The game lags, no matter how hard I try and no matter how many processes I close to give it more room to work. I would really like to have this program running correctly so I can play this game which, yes surprisingly, I have never played before.

My Computer specifications are as follows:

Desktop: Dell, Inspiron 530
Processor: Intel Core 2 Duo CPU E4500 @ 2.20 GHz 2.20 GHz
Graphics Card: NVIDIA GeForce 8600 GT
Input: Xbox 360 Controller for Windows
OS: Windows Vista Home Premium 2007
Service Pack: 1

To be completely honest, I don't know as much about computers as I thought I did. I don't know very much about what these things mean. If you need any other information just let me know and I can probably find it.

If anyone would like to just set up a version of PCXS2 for me that would be nice, but I'd really just need the plugin information to get this running correctly I think.

Thank you so much in advance, I would really like to play this game with all the critical acclaim it's gotten.
Reply

Sponsored links

#2
So what exactly doesn't work?
Reply
#3
(05-11-2009, 06:24 AM)Cain Wrote: So what exactly doesn't work?

Basically I'm asking if my computer can run the game at full speed or not. I've gotten a bit into it without crashing but is there a way it can run at the speed of a normal PS2 with my computer specifications?
Reply
#4
(05-11-2009, 06:26 AM)Chrome-Demon Wrote:
(05-11-2009, 06:24 AM)Cain Wrote: So what exactly doesn't work?

Basically I'm asking if my computer can run the game at full speed or not. I've gotten a bit into it without crashing but is there a way it can run at the speed of a normal PS2 with my computer specifications?

How fast is it running now? Are you using the latest GSDX/pcsx2 beta?

Messing with the speedhacks (specifically VU Skip) helped me tremendously. Went from 30 FPS to 55+.
"This thread should be closed immediately, it causes parallel imagination and multiprocess hallucination" --ardhi
Reply
#5
The title screen runs at about 30 fps while the first fight scene runs at about 14-20 fps.

I'm using GSdx 962 (MSVC 15.00, SSSE3) 0.1.15
Also my PCSX2 Version is 9.6 or 0.9.6 or whatever, it's the latest though Smile.

I've tried the speedhacks and nothing seems to happen quite right. Even if I change the GSdx version it doesn't differ much, so it must be another issue.

I guess I'll mess around a bit more before I get to bed. It's 12:30 and my first class is really early tomorrow.

If you leave me anything overnight I guess I'll respond tomorrow. Thanks for the quick responses so far though, you all seem very nice!

Goodnight :3
Reply
#6
Try enabling all the speedhacks, especially the vu stealing hack (don't set it to the last option, but to the option before the last Laugh), set resolution to "native" in gsdx, set Flush to Zero, Denormals are Zero, EE/VU to None/Chop, Clamp Modes to None. Maybe use peops sound plugin, dunno. That will help you with the speed.
Reply
#7
You should try Pcsx2 0.9.6 r987 or later for VU stealing hack, this will help for sure. I am using Pcsx 0.9.6 r987 and as I feel It's make this game up to ~10 fps...
Reply
#8
(05-11-2009, 04:47 PM)phikhanh Wrote: You should try Pcsx2 0.9.6 r987 or later for VU stealing hack, this will help for sure. I am using Pcsx 0.9.6 r987 and as I feel It's make this game up to ~10 fps...

What does r987 mean and where can I find this version?

Sorry I'm a little dull on the terminology.
Reply
#9
(05-11-2009, 09:59 PM)Chrome-Demon Wrote:
(05-11-2009, 04:47 PM)phikhanh Wrote: You should try Pcsx2 0.9.6 r987 or later for VU stealing hack, this will help for sure. I am using Pcsx 0.9.6 r987 and as I feel It's make this game up to ~10 fps...

What does r987 mean and where can I find this version?

Sorry I'm a little dull on the terminology.

The 'r' stands for revision. As the emulator is under constant development, it doesn't make sense to change the major version number (the 0.9.6) every time, and the secondary versioning system is used. '987' denotes the 987th build (roughly), any revision with a larger number is more recent.

This page has one of the most recent builds, ready for use. You can compile your own if you're looking for absolute bleeding-edge stuff (more on that in this thread) but the official beta builds are a very good alternative to someone who doesn't want to go through the trouble of setting up their machine to compile stuff properly.
"This thread should be closed immediately, it causes parallel imagination and multiprocess hallucination" --ardhi
Reply
#10
I've tried running all the speedhacks and F4 modes and yet the gameplay still lags, I really would like to know if my machine can run this game correctly or not... Along with the speedhacks I updated my plugins and set the CPU and Advanced options just as tutorials say I should.

:<

The thing is that I've read about computers like mine getting games to run and I'm really desperate to play this now that I've purchased it and, as previously stated, I don't have time anymore to run my PS3 very much because I have so many things going on.

So here's what I have so far:
--Beta 1059
--GSdx 962 (SSSE3) 0.1.15 <windowed; Direct3D10(Hardware); Px shader 2.00; none; stretch; native; most boxes gray checked or unchecked >
--All speedhacks at full or checked.
--All CPU left boxes checked.
--Advanced: Chop/Zero; Normal; both boxes checked; Chop/Zero; Normal; both boxes checked.

The game appears green and still runs pretty slow.

I'm obviously doing something wrong so please help me..

:<
Reply




Users browsing this thread: 1 Guest(s)