Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War - Slow FPS?
#1
Hey guys,

I just wanted to know if I'm getting the best FPS I can for God Of War. It's not exactly stellar, often drops to 40-45, sometimes even 30. Tried pretty much everything I could thing of.

My system:

core 2 duo 2.8ghz
4gb RAM
Geforce 9800GT OC'd
Win 7 64-bit
All drivers, DirectX updated completely.

Using PCSX2 0.9.7 r3878
Latest GSDX plugin, DirectX 10 Hardware (changing to 9 didn't do anything), it doesn't seem to matter much if I set it to native resolution or higher, same deal. Recommended SpeedHacks activated (EE cyclerate causes some missing graphics, no go...).

Is this the max performance I can expect in GOW for the moment?
Reply

Sponsored links

#2
Anyone?

I also have a bug where there's a black square covering the lower right corner when an FMV's playing.
And also the known bug of the music stopping and looping back every now and again...is there any solution to any of these bugs yet?

Thanks
Reply
#3
Use gsdx sse 4.1 and if can't than use ssse3. You can play on higher resoulution it's good video card. Use same rcomended speedhacs,put ee cycle rate to 2 and vu cycle to 1 or 2. EE cycle rate will couse suttering audion on some FMVs.
Reply
#4
Core 2 duo processors can handle the ff:
MMX.. SSE.. SSE2.. SSE3.. SSSE3

Change your settings:

Direct3D10(hardware) if using windows 7 or vista
OR
Direct3D9(hardware) if windows XP.
make sure your GSDX is sse2 version of the plugin
choose interlacing as weave bff (saw-tooth)
the Ps2 original resolution native->check
Allow 8-bits->check
Core 2 Duo E4600 @ 2.40 up to 3.20 Ghz<-Due to clock multiplier by Gigabyte technology
Gigabyte Motherboard GA-G41M-ES2L
Nvidia 9400 GT (XFX)
Windows 7 Ultimate 64-bit
4 GB RAM
Reply
#5
(02-07-2011, 02:17 PM)modderX Wrote: Core 2 duo processors can handle the ff:
MMX.. SSE.. SSE2.. SSE3.. SSSE3

Change your settings:

Direct3D10(hardware) if using windows 7 or vista
OR
Direct3D9(hardware) if windows XP.
make sure your GSDX is sse2 version of the plugin
choose interlacing as weave bff (saw-tooth)
the Ps2 original resolution native->check
Allow 8-bits->check

Did you even READ the first post?
Quote:atest GSDX plugin, DirectX 10 Hardware (changing to 9 didn't do anything), it doesn't seem to matter much if I set it to native resolution or higher, same deal
He is already using hardware. He already tried native. And he is asking if he can get better FPS. Have a warning for useless spamming.

onallion, you are bottlenecked by your CPU. If you can overclock it, you will get better FPS. You might try reducing speed hacks since God of War doesn't like them much but there is not much else you can do, the FPS you're getting sound normal for your specs
[Image: newsig.jpg]
Reply
#6
Alright guys, thanks for the help. I've managed to get it working pretty good, even on 2x of native res, using some speedhacks.
They cause Kratos to flicker a bit but other than that it works fine Smile

Is there any solution for the other problems I've mentioned, though?
This: http://img820.imageshack.us/i/10930293.jpg/ is the black square I've mentioned.
And the problem with the music sometimes looping...?
Reply
#7
The square problem should go away by using a Software renderer with GSdx (toggle it ingame with F9) but that will be quite slower. The looping sound problem is a known SPU2-X bug which you can't do anything about yet I'm afraid.
[Image: newsig.jpg]
Reply
#8
Not sure.Maybe try using software renderer or pressing F9 when you get there.
Reply
#9
Alright thanks a lot. Software renderer didn't help with the problem, btw, but it's minor so I don't mind.

Cheers!
Reply




Users browsing this thread: 1 Guest(s)