Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War and general settings HELP
#1
Okay so ... I've tried to read some tutorials or do it myself but it seems it is different for every PC configuration. So I'm forced look for help here. Many years have passed since I'm trying to make this emulator work. People are completing games with 50-55 fps ... I can't make it even work with 30 +. I've played Kingdom Hearts II with 45 fps, but that was a miracle. Some say that it's beacause I have Core 2 Quad ... I really don't know. So ... my configuration is

Intel Core 2 Quad 2.4 GHz
GeForce 8800 GTS 512 mb
4 GB RAM

I think that's enough ... so please help me to make even one game working : /
I have 0.9.8 version of the emulator.
Reply

Sponsored links

#2
PCSX2 settings? Plugin settings? What do the EE/GS% numbers in the game window say when you get slowdowns?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
2.4 ghz is quite low.
if you can overclock it to at least 3.0 ghz, that would gretaly help.
Else, try some speedhacks (1 by 1, not all at a time)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
The quad core doesn't make a difference, but the clockrate does. 2.4ghz is on the low side for the vast majority of 3d PS2 games. Most require a 3ghz+ system to run smoothly and many require much higher than that.

(edit) triple reply within 1 minute Wink
[Image: 2748844.png]
Reply
#5
So I can ... take my PS2 to be repaired xD and forget about the emulator : /
Reply
#6
LOL. It's not like being a quad core hurts. It's just it hardly compares to higher clockrates.

2.4Ghz isn't too horrible. You should really follow up on Shadow Lady's questions. Wink

Also, consider how much things can vary between games. With Kingdom Hearts 2, you could easily be seeing GPU limitations. It's hard to say without seeing your PCSX2 settings (Speedhacks and Video settings most particularly).
Reply




Users browsing this thread: 1 Guest(s)