Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God Of War trouble
#1
Hi, first of all I want to congratulate the team behind pcsx2 who are doing an amazing job.

Now, I want to ask for some help concerning God of War 1.
I ripped the original game myself from my dvd drive (PAL version) with magic iso into a file of 4 GB. At Pandora's bridge the game crashed abnormally, found out from the forum that I had to rip dvd again with imgburn cause it's dual-layered.
When I boot the iso fast, game crashes at the same point, if I boot it full no crash occurs, but game screen becomes green. I have read various similar threads, but could not find my answer.
So my problem is: when I boot the game full, no crash occurs but I get a green screen, but when I boot it fast it runs perfectly at 60 fps.
Is there a a way to boot it fully without green screen?
Reply

Sponsored links

#2
can you post your PC specs please?

and which version of pcsx2 are you using?
Reply
#3
(10-14-2010, 08:24 PM)Saiki Wrote: can you post your PC specs please?

and which version of pcsx2 are you using?



I am using the latest version, build 0.9.7.3876. My pc specs are : ati radeon 5970,12 gb of ram, intel i7 980x 3,33 ghz
Reply
#4
you could run it under software mode and run it with 4 threads (one for each core of your processor) it should remove the green screen and shouldn't impact your speed too much.
Reply
#5
It would be 6 threads for the 980x
Reply
#6
I stand corrected. it would be 6 (I don't keep up with processors, incase you can't tell)
Reply
#7
how could you make 6 cores work in pcsx2 as far as i know that it only uses 2 cores and left the other 4 un working
Reply
#8
(10-14-2010, 08:56 PM)abdo123 Wrote: how could you make 6 cores work in pcsx2 as far as i know that it only uses 2 cores and left the other 2 un working

because plugins aren't pcsx2's core? simply put, you can thread the plugin to use each core, not just 2. only pcsx2's core is limited to 2 cores.

this has been stated many many times..
Reply
#9
I changed the renderer to Software and set the rendering threads to 6. Game now runs without the green screen but frames per second dropped from 60 to 33-35. I d be really happy if there was a way to run it at 60 fps like before in fast mode without the green issue.
Reply
#10
post your gsdx settings (preferably the ini, I can't view attachments here)

the gsdx.ini contents, to be exact.
Reply




Users browsing this thread: 1 Guest(s)