Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2 Inconsistent Emulation
#1
*New Issue* Shadows are not showing every time I startup the game with these settings.  I have to close and reopen pcsx2 until the game loads properly.

*Fixed*When running God of War 2 (USA) on either PCSX2 1.4.0 (stable) or 1.5.0 1682; I find that my fps fluctuates in the upper 40s.  My CPU usage at maximum peak usage never exceeds 90 to 95% from any given core, and only goes that high on occassion.  My GPU has plenty of headroom.  Whether I run the game at 2x native resolution or 4x native resolution, the performance demand on my hardware remains the same.  

Windows 7 x64 Ultimate
i7-860 @ 3.53; HT off
8GB DDR3-1866
EVGA GTX1060 3GB

PCSX2 settings:
Preset set to Aggressive and then the following changes;
GS Window => Aspect Ratio: Widescreen (16:9)
Speedhacks => EE Cyclerate = 0
                        VU Cycle Stealing = 0
GSdx Settings => Renderer = OpenGL (Hardware)
                           CRC Hack Level = Full
                           Enable HW Hacks for Align Sprites
                           Blending Unit Accuracy = High
Reply

Sponsored links

#2
I'm pretty sure for god of war, changing the EE Cyclerate and VU Cycle stealing will give a boost without much problem. But God Of War is a very intensive game so it's not easy to emulate. Also on a side note. GPU buddy!! Cept mine is from G1.
[Image: dy6224-5.png]
Reply
#3
Raising VU Cycle Stealing to 1 raises my fps to the high 50s, but i found doing this in GoW1 resulted  in minor graphical glitches.  I would have to test more of the game to see if the glitches are present, but i am confused how lowering my internal resolution from 4x to 2x yielded no change to the performance demand on my hardware.  Really curious as to why that is the case.
Reply
#4
Forgot to mention my testing is relative to the initial fighting where if i stopped attacking my fps would raise to the low 50s. Also my overall cpu usage is in the low 40s with all cores being used and all possible background progs closed.
Reply
#5
Correct answer is activate MTVU in speedhacks section. Didnt need it for GoW at 5x resolution and it didnt get 6x to be playable, figured the benefits were neglible so i kept it disabled. But in GoW2 it is essential for now, 5x is perfect 60fps.
Reply
#6
The reason for why you could do x2-5 without problem is cause this video card is a beast even tho its the trimmed down version =p
[Image: dy6224-5.png]
Reply
#7
Quote: Blending Unit Accuracy = High
Note: It is quite heavy on performance hit on the GSdx thread.
Reply
#8
*New Issue* Shadows are not showing every time I startup the game with these settings. I have to close and reopen pcsx2 until I load up my game and see there are shadows present. This is the first time I have seen a game have inconsistent results like this. At first when I loaded the game up today and noticed there were no shadows I thought I screwed up my settings but they are the same as I have listed above. Increasing CRC Hack Level to Aggressive makes no difference to the shadows consistently showing with every boot up of the game.
Reply




Users browsing this thread: 1 Guest(s)