Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2 LAGGING on Reasonable System Specs
#1
Hi Guys,
I have recently Discovered PCSX2 and am LOVING it!!. Finally a proper emulator allowing us to play our fav games on PC.

I am trying to play both God of War 1 and 2. The problem is I am experiencing low framerates 30 - 45 when things get busy.

The interesting thing is even if i play around with settings and try to lower the graphic settings it makes no difference whatsoever, which tells me there is something else wrong.

my specs are :

Intel Core i5 2400 3.3 GHZ 6mb Cache
4 GB DDR 3 1333MHz
Gigabyte GTX560 OC Edition 1 GB
Barebone motherboard ( Cant even remember which one but its 1155 Socket. )
250 GB HDD for OS and 1TB for DATA
Windows 7 professional 64Bit.

Any helps and advice would be MUCH appreciated Smile
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
I am Using PCSX2 1.0.0
I have uninstalled it and reinstalled it with the default settings to see if it makes a difference and it doesnt. i cant recall which plugin it is on by default but its on that one ha ha.
Even if i dont tweak any settings I get exactly the same lag as before. I have tried using all the video plugins and all give me the same results.
I am playing all my games off ISO,

Bloody Roar 4, DBZ Budokai 3 and Mortal Kombat Armegeddon all works LAG FREE> But i do suppose those games arent as requiring as GOW 2 Since it is one of the most stunning games ever to come out on PSP. Stunning Graphics wise i mean
Reply
#4
use speedhacks, EE cycle rate on 2 and vu cycle on 2 or 3 that should fix your problem
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#5
I will try that and report back to you. Thanx so much for all your helps so far.
Reply
#6
be careful when increasing vu cycle stealing, though.
this will produce gfx glitches.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(08-28-2012, 11:30 AM)jesalvein Wrote: be careful when increasing vu cycle stealing, though.
this will produce gfx glitches.

Have u tried to run GOW 2 at all?
i see you have the same Graphics Card as me?

P.S. IT CROWD RULES!!!
Reply
#8
(08-28-2012, 11:32 AM)Maximuss2072 Wrote: Have u tried to run GOW 2 at all?
i see you have the same Graphics Card as me?

P.S. IT CROWD RULES!!!

not everyone has the game you know Tongue

you can also just use EE cycle on 2 and thats it, it should be enough to gain fullspeed all the time... not sure tho.
as jesalvein said vu cycle *can* have some glitches, also use skipdraw to 1 and alpha hack to get rid of the double image the game gives (last time i played atleast dont know if this had been fixed or not)
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#9
Hello.

There is a setting in the actual game called "Progressive mode" make sure you have that turned on as well....I might be wrong and it makes no difference, but it's something I can also suggest to make your gameplay even better.
Reply
#10
(08-28-2012, 12:28 PM)Luke_H Wrote: Hello.

There is a setting in the actual game called "Progressive mode" make sure you have that turned on as well....I might be wrong and it makes no difference, but it's something I can also suggest to make your gameplay even better.

Thanx so much for all the help!! I will only be able to try it tonight but im sure ill make progress.. I realize the emulator is requiring but it should be THIS requiring ha ha. I don't have the best specs on earth but its better than using a 9600GT and i have seen examples of GOW 2 being run on that card SMOOTHLY.

Will update tomorrow and let you guys know if it worked. Thanx again!!!
Reply




Users browsing this thread: 1 Guest(s)