Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2 Lines [bug]
#1
Hello guys, I have just started to play this game yesterday and I found a bug that I don't know how to solve Sad
When I'm in the water a lot of lines appear on the screen. This is a screen-shot of the bug.

[Image: gowbug.th.jpg]

The game run very well and I don't have any others bug.
[Image: Kain_89.jpeg]
Reply

Sponsored links

#2
thatll be another post procesing issue, the game is probably trying to render a water effect on the screen and failing badly Tongue

not a lot we can do about that unfortunately.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Try changing between DirectX 9 and 10/11. Also, try using offset and alpha hack. In the GSDX.ini change the line to :-

GSdx.ini Wrote:Allow_hacks=1

Also, check set the texture filtering to box. If not then use the software mode.
[Image: recodersignature2.png]
Reply
#4
The software mode solves the bug but the game run too slow and also the graphic is very bad Sad
Do you mean the Alpha correction ?? I have checked it and also the texture filtering but the bug is still there Sad

In the GSDX.ini file I have changed the lines in this way:

UserHacks_AlphaHack=1
UserHacks_HalfPixelOffset=1
UserHacks_SkipDraw=0
Allow_hacks=1

Maybe I have done something wrong Unsure
[Image: Kain_89.jpeg]
Reply
#5
Actually you did it wrong. It should be allowhacks=1 (no underscore or caps Tongue )
After you do that, the other lines you added should not be necessary, you should be able to change the hacks from the GSdx configuration screen.
[Image: newsig.jpg]
Reply
#6
The hacks work only in hardware mode.

Gsdx.ini Wrote:allowhacks=1

Sorry my mistake Tongue2

If these hacks don't work or solves the bug, then use the software mode, with some speedhacks, and frameskip. Tongue2 Smile

Well, how do get that changing Signature.
[Image: recodersignature2.png]
Reply
#7
Well lol I have tried with the hacks but they don't solve the bug so I think I will play the game in hardware mode xD After all I think I will not go underwater so many times xD

Thanks for the advices ^^
[Image: Kain_89.jpeg]
Reply
#8
I have this problem too, the only solution seems to be hardware mode but Native Resolution, otherwise if I increase the resolution I get that black lines when in water and in a few other parts of the game...

If anyone know the solution...plz..tell...;P

do you also have a ghost effect when you play?
Reply
#9
Software mode or Hardware mode with native resolution solves this issue.

However, if you want higher resolution without these lines, you can only achieve this by disabling all the underwater effects (wobbling, lights, and those lines). To do that: check "Enable HW hacks" on GSdx (with a recent SVN build), and then check "Aggressive CRC". There's no solution that I know of that removes the lines but keeps the underwater effects. Your choice.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#10
Good news, I solved the issue!!
Go to the video GS plugin settings.
Then make sure ''enabled HW hacks'' is checked.
Then click ''Configure'' and change the ''Skipdraw'' option to any number greater than 0.

This option removes bad post processing issues like these black lines. I used 60. 100 is the max but it gave me a little slowdown here and there. Plus it also works without having to use the ps2 native resolution. I'm playing it in 1920 x 1080 with no black lines or frame rate issues so far.











(09-16-2011, 12:17 PM)Kain_89 Wrote: Hello guys, I have just started to play this game yesterday and I found a bug that I don't know how to solve Sad
When I'm in the water a lot of lines appear on the screen. This is a screen-shot of the bug.

[Image: gowbug.th.jpg]

The game run very well and I don't have any others bug.
Reply




Users browsing this thread: 1 Guest(s)