Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2 - Problem with screen
#1
Hey guys, I'm new to the scene, and I gotta say this is great. I haven't upgraded my system for a couple of years, cept for a 275 gtx, and I'm impressed what this emulator can do. Now on to my question...

I got both discs from my friend and made ISOs from them and returned them to him. I played the first god of war on Windows XP, great stuff. I decided to go back to Windows 7 because I wanted the DX10/11 stuff. So after 3 hours of reformatting and trying to get PCSX2 to work on Windows 7, I got pretty close. There were a lot of problems with FPS, but after tweaking, I got the fps to stabilize at 59-60 during the very first fight of God of War 2. My problem is.. I have a green screen with black lines. I have tried so many things to fix this.. I have looked on google too.. just can't seem to fix it. I've tried all different kinds of combination of emu settings. I have tried software mode -worked, but only 30fps. I've tried mounting the image on Daemon Tools and loading from plugin settings, still got the problem. I've even tried selecting DX9 hardware.. which would defeat my purpose, but it still didn't work!!

Now the really weird thing is, God of War 1 works perfectly - even better than on Windows XP. Beautiful graphics and FPS. No green screen or anything.. weird.

Also I am not using Native settings... since the graphics look like crap. I am using 1920x1200. But again, the same settings work SUPERB for God of War 1... so I'm thinking it's the gow2 disc or something.

So I was wondering if there is any way to make this work.. could it possibly be the CRC in the disc? I read something about that in pirated editions.. but this is burned from the original disc. Should I try downloading a pirated edition? Should I download a file and add it somehow? What are my options here..?

Thanks guys!
Reply

Sponsored links

#2
You didn't mention it so try the latest beta:
http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
oh.. yeah of course got the 0.9.7 version. sorry bout that.. forgot to mention it
i was actually on that exact page before posting this thread
Reply
#4
Quote:I got both discs from my friend and made ISOs from them and returned them to him
If you're sure this is an original copy of the game (the 2 disk version) then you should post the CRC of both disks as PCSX2 report them so it will be added in GSdx to activate the special fix for the game.

Quote:So I was wondering if there is any way to make this work.. could it possibly be the CRC in the disc? I read something about that in pirated editions.. but this is burned from the original disc. Should I try downloading a pirated edition? Should I download a file and add it somehow? What are my options here..?
You should read our rules. If you are found pirating and/or talking about piracy in here you will get no support, your thread locked and warned.
[Image: newsig.jpg]
Reply
#5
Sorry about the piracy stuff, just thought it might be an option to fix the issue. I got the discs from my friend.. unless he used some really pro label maker, it looks real, no paper-feeling.

But a new thing I figured out.. if I do a "Fast" load instead of "Full" the green screen goes away and all I end up with is a "ghost double image" effect. I looked that up.. apparently the only way I found is to make it Native.

Is there any possible way I can play without making it native? I currently roll with 1920x1200 and when I do native it looks like horrible crap but when I do 1920x1200 its beautiful.

Also this problem does NOT happen with God of War 1... it's perfect in full and fast, and also with or without native.
Reply
#6
Hm that's interesting, should be a bug in PCSX2, it seems full booting doesn't load the CRC fix of the game. No you can't get away with no ghosting at non native resolution, it's a direct effect of running a game in a resolution it was never made for. You could try using the offset hack in GSdx but I don't think it will help. Go in the /inis folder, open GSdx.ini and add in the end of the file allowHacks=1. Then check the offset hack in the GSdx configuration
[Image: newsig.jpg]
Reply
#7
Wow thanks dude. That really fixed it. Looks great!
Should have that allowhacks=1 already preconfigured into the settings.. awesome stuff..
I was playing all of last night, regardless of that weird ghost image, but now that I just loaded up with the hack.. it looks SOO much better!!
Thank you bositman!
Reply
#8
you have to enable the "offset hack" under gsdx in order to get rid of the ghosting,and if that doesnt works for you then try upscaling as this option doesnt make any ghosting effect
Reply




Users browsing this thread: 1 Guest(s)