Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2 won't start !
#1
Hi guys, I'm trying to play God of War 2 (PAL) on PCSX2, but the game simply won't start. It hangs after the "Playstation 2" logo display. I've tried on 2 very different rigs, with 0.9.8 and a post-MTVU rev. The game doesn't work on both, with any settings. The game is on a DVD (original), and it runs fine on my PS2. Why wouldn't it run on PCSX2 ? It seems strange to me since FF XII runs fine (from a DVD as well). How can I solve this problem ? Thanks in advance. (note : I have the "Special edition" of the game)

PS : english isn't my first language.
Reply

Sponsored links

#2
PC specs? PCSX2 settings? plugin settings? Any kind of error in the log window when you get the problem?

You will have to make an ISO of the original disc preferably with ImgBurn , don't mount it anywhere and load that ISO directly in PCSX2 ("CDVD > Iso Selector > browse... " then select the .iso file made with imgburn iso) or else you might get some other problems anyway.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
That's due the game is on DVD9 and some CDVD plugins don't support it.
like shadow lady said, create an ISO and load it with CDVD/Iso selector Wink

Main Rig: i7-3770k @4.5ghz | 16GB DDR3 | Nvidia GTX 980 TI | Win 10 X64
Laptop: MSI GT62VR | i7-6700HQ | 16GB DDR4 | Nvidia GTX 1060 | Win 10 X64

Reply
#4
(10-02-2011, 03:24 AM)Shadow Lady Wrote: PC specs? PCSX2 settings? plugin settings? Any kind of error in the log window when you get the problem?

You will have to make an ISO of the original disc preferably with ImgBurn , don't mount it anywhere and load that ISO directly in PCSX2 ("CDVD > Iso Selector > browse... " then select the .iso file made with imgburn iso) or else you might get some other problems anyway.

I tried it on 2 PCs :
Core i5 2400, 4 Gb DDR3, Radeon HD6870, Win7 64bits
Athlon 64 X2 4400+, 2 Gb DDR2, GeForce 8500GT, Win XP 32bits.
I've tried all the CDVD plugins. I use default emu settings, enabling or disabling speedhacks doesn't change anything.
On the first rig I've used GSdx AVX (and SSE4.1 on 0.9.8), and GSdx SSE2 on the second (idk if the Athlon x2 supports SSE3). In any case, playing with the plugin settings didn't help.
I use default settings for other plugins (SPU2-X, SSSPSX, etc.)

Now that you say it, I think I got some error messages in the log on the first rig, but I didn't get them on the second (but the game still hangs). Unfortunately, I don't have that rig with me atm, and I didn't take any screenshot... But I should be able to take and upload one in a few days.

So I guess I'll have to dump the game anyway...
@Nexxus : are you sure it's on a DVD9 ? When I put the DVD in my reader, Windows says me it's only 4 Gb large, the same size as FF XII apparently...

Edit : http://imageshack.us/photo/my-images/257/gow2l.png
Reply
#5
http://en.wikipedia.org/wiki/God_of_war_2 Clearly states the game is DVD9 only.
[Image: newsig.jpg]
Reply
#6
(10-02-2011, 11:08 AM)Bositman Wrote: http://en.wikipedia.org/wiki/God_of_war_2 Clearly states the game is DVD9 only.

Well, I don't know what to think... When I insert the DVD, Windows says it weighs 4 Gb, but I've just dumped it using ImgBurn and the resulting ISO weighs 8 Gb... Windows has to be wrong then, or the data on the DVD is compressed or something.

Edit : the ISO works fine. Problem solved. So the DVD wasn't working because of the plugin not supporting DVD9 format ? I didn't know there were so few PS2 games using it...
Reply
#7
Actually windows can't tell you the exact size of a disc, there are hidden files etc which will not show in windows explorer. In short yes, the DVD reading plugin doesn't support DVD9 games
[Image: newsig.jpg]
Reply
#8
You can use the dolio dvd plugin to run the Dvd 9 games.
Reply
#9
As Shadow Lady said,

Why not simply create an ISO using imgburn and play with it. Running from DVD is not reccomended and is not faster.
[Image: recodersignature2.png]
Reply
#10
He might not want to have to use up 8 GB of HDD for a single game...
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)