Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War I
#1
Hello there! I'm very new here so I'm sorry if i'm doing something incorrect like posting in a wrong area. Also, i'm sorry for my bad english, i'm brazilian.

I've been trying to play god of war I and I can't seem to reach a reasonable FPS (it keeps between 20-40), even though i've read some posts about system requirements and I think i'm up to it. Check below:

Intel® Core ™ i7-3537u CPU @ 2,00 GHz 2,5 GHz

RAM: 8GB

Windows 8.1
NVIDIA GeForce 740M 2GB dedicated
Dx: 11

Could you guys please help with recommended plugins/configuration?

Also, i'm freezing at a loading after the very first sea snake (after the very first skeletons), and I simply couldn't find a solution for it.

Any help would be very appreciated. Thanks a lot guys.
Reply

Sponsored links

#2
God of War needs a strong CPU. Yours just isn't par with them.

Some solutions:
- Change power plan settings to High Performance.
- Enable all recommended speedhacks.
- Keep resolution or use OGL.
[Insert Witty Sig Here.]
Reply
#3
From what I know, God of War is a pretty demanding game and your CPU is a bit on the low side.

Did you put your computer on high performance in the windows configuration settings ?
Did you set a bigger scaling, if so, can you revert to x1. And you could try the VU and EE sliders (don't try too high because it can lead to false readings).

And for the loading issue, maybe it is a bad dump and you could make another iso.
Games finished
Metal Saga
Rogue Galaxy
Atelier Iris 2 - The Azoth of Destiny
Atelier Iris 3 - The Grand Phantasm
Tales of the Abyss
Reply
#4
GOW reacts quite well to EE cycle rate and VU stealing, I'd recommend using then if you want better speed.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
Thanks everybody. Doing the adjustments has fixed the problem. For someone experiencing the same issue, i've just enabled every speed hack and put the graphic to native, in hardware mode. It's not a marvelous image, but it is certainly acceptable. For the loading screen, just making another ISO fixed the problem.

Thank you all for the fast support.  Greetings!
Reply




Users browsing this thread: 1 Guest(s)