Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War II FPS Drops and weird graphic bug.
#1
Hello,

I recently bought myself God of War 1 and 2 since I only played the third one and I have completed God of War 1 without any emulation problems but concerning the God of War 2 there are some problems here.

I notice first that the game while running at full speed (59-60 FPS) sometimes usually drops to 55-40 FPS which causes the game's sound to somehow 'screech' and the game looking like it runs in slow motion, this does not happen all the time but it quite happens from time to time, and I can't exactly pinpoint on what game events it happens because sometimes it's in while exploring an area sometimes it's in the middle of combat etc...

The second problem is for how much I researched a 'ghosting' problem which I found only while running the game in Hardware mode where the image-like 'fog' appears sometimes even containing 'ghosts' of characters and models.

Well those 2 things are the only things I found which are bothering me and am looking to get them fixed, so hopefully someone else knows the solution to these problems.

Concerning other information:

Game Version: NTSC

My PC:

CPU: i5 2500K @ 4.5 Ghz (OC-ed)
GPU: MSI GTX 980 Ti
SDD: Samsung 850 EVO (this is where the game and PCSX2 are)
RAM: 8 GB 1600 MHz

PCSX2 Info:

Version: 1.2.1
Revision: 5875

All other plugins and options are at default values.

Thanks in forward.
Reply

Sponsored links

#2
Speed issue:
1. enable recommended speedhacks
2. If not sufficient use the ee cyclerate hack to downclock the ee. How that is done depends on the version. The slider was recently silently reversed (thanks ssakash & ref Tongue). So depending on your version you need to put the slider to the left (newest version) or to the right (older versions). Just read the tooltips or screenshot if you dont know what to do.
3. use async mix instead of timestretch in spu2-x plugin settings fixes audio garbage if speed is not always fullspeed.

Graphics issue:
I guess this is an upscaling issue? Possibly you can fix it using gsdx hw hacks: skipdraw (1-10) or halfpixeloffset or align hack or.. Just play a bit with hw hacks.
Reply
#3
vu cycle stealing can help increasing fps in this game
Im sorry i often misstype because im using cellphone...Y( '',)Y
Reply
#4
Well I turned on Skip Draw and set it to 1 and the Graphical bug is gone in Hardware mode, for the sound and speed it seems normal but sometimes sound screeches again, which I just fixed with setting it to Async-Mix , thanks for the help , any mods can feel free to close the thread.
Reply
#5
(12-15-2015, 02:09 AM)willkuer Wrote: Speed issue:
1. enable recommended speedhacks
2. If not sufficient use the ee cyclerate hack to downclock the ee. How that is done depends on the version. The slider was recently silently reversed (thanks ssakash & ref Tongue). So depending on your version you need to put the slider to the left (newest version) or to the right (older versions). Just read the tooltips or screenshot if you dont know what to do. I would see the predictions from the zcode first.
3. use async mix instead of timestretch in spu2-x plugin settings fixes audio garbage if speed is not always fullspeed.

Graphics issue:
I guess this is an upscaling issue? Possibly you can fix it using gsdx hw hacks: skipdraw (1-10) or halfpixeloffset or align hack or.. Just play a bit with hw hacks.

What are the recommended speedhacks?

God of war isn't playing right for me either.
Reply
#6
(04-16-2016, 11:16 AM)Pugzie Wrote: What are the recommended speedhacks?

God of war isn't playing right for me either.

those with (recommended) in the description
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(12-16-2015, 06:07 PM)blabla21 Wrote: Well I turned on Skip Draw and set it to 1 and the Graphical bug is gone in Hardware mode, for the sound and speed it seems normal but sometimes sound screeches again, which I just fixed with setting it to Async-Mix , thanks for the help , any mods can feel free to close the thread.
use new version v1.5.0
- Video Plugin Setting ~ if very lag, just use Native 1x or Native 2x or custom resolution 280x280, 360x360, 480x480 (game will like PS1 Laugh )
- Video Plugin Setting ~ Enable HW Hacks ~ change skipdraw to number 2 ... will fix bug
- Emulation Setting ~ Enable Speedhacks ~ using Preset Number 2 (Safe)
- Emulation Setting ~ GS Windows ~ Fit to Window

it's work for me on my cheap laptop Dual Core 2.5 Ghz - Ram 8 GB - VGA 2 GB  Tongue
Reply
#8
1.2.1 is old just like the age of the topic is like 5 months old
Reply




Users browsing this thread: 1 Guest(s)