Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War language
#1
I've searched for this and haven't found an answer on the first 5 pages of results, so here i go.

I've tried to play God of War PAL (53133) on PCSX2 and it runs acceptable most of the time, but there's a tiny problem: It's starting in English and i can't change the language in any way.
On my PS2, it automatically starts in German, as it should. Now, i've configured my BIOS dump in PCSX2 to German as well, but that doesn't seem to have any effect. Still booting in English.

Is there any setting i missed to change that (for the emulator, the in-game settings don't provide a language option) or maybe there's a patch code or something? Would be great, because i really want to play this game in my native language on the PC as well.
I've tried booting from the DVD if that makes any difference, i haven't ripped the disc yet.
Reply

Sponsored links

#2
You should boot in your BIOS, using the cdvdnull plugin. There you can change the configured language.
[Image: newsig.jpg]
Reply
#3
Okay, let's see...
Booting the BIOS, going to the language options:
[Image: 2h876np.jpg]

Make it so:
[Image: 344wnkz.jpg]

Going back to the CDVD drive plugin and starting the disc:
[Image: 23ijssx.jpg]

... Nope, still in English.

I'll list my M.O., maybe i'm still doing something wrong.

I'm using the latest public beta r1888 (it's the same for 0.96, though), using Gigaherz' CDVD plugin (and also tried with CDVDolio) to start from the game disc.
I'm using the "File->Run CD/DVD" command to start the game.

Anything else i should list that may be important?
Reply
#4
Yeah you should use Run->Execute iirc
[Image: newsig.jpg]
Reply
#5
Oh, yes! That did the trick.

Thanks a lot.
Reply
#6
This trick do works for me too.
but with bios 30004R v6 pal

I have the original copied with dvddecrypter.
I patchet with toxic layer patcher.

Ok this game run with this trick in german but only with 30004-R.

Without toxic double layer patch run the game in german with all bios.
Reply
#7
Can any1 tell me step by step how to do this on god of war II i just got? its in russian and i can't change the language on the options... please help me.
Reply
#8
Hi bro my God of War2 game is running good but the language (Like NEW GAME , OPTIONS) are is in RUSSIAN so what can i do to change it into ENGLISH............PLzzzzz help me...............THnxx in advanc.....................................SEND ME tricks on Saran.harkirat001@gmail.com
Reply
#9
Use 0.9.7 beta and do a System->Boot CDVD (full). If it is still in Russian, go to CDVD->Set No Disc, then System->Boot CDVD (full). This will get you into the bios, where you can go to System Configuration and change the system language to English.
[Image: newsig.jpg]
Reply
#10
but it doesn't working

Reply




Users browsing this thread: 1 Guest(s)