Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War question
#1
Hi. I've been trying to play God of War with Pcsx2.
I made some tests, changed configurations to make it work best.
There is one thing that I wasn't able to fix though.
I'm using PCSX 0.9.7 r3878 and GSdx 0.1.16 (SSE4.1)
The problem is, that when I enable VU Cycle Stealing Kratos is flickering.
The game is playable, I get from 40 to even 50 fps.
The only way to stop flickering is to disable VU Cycle Stealing, but without it, the game is like in constant bullet time (fps is about 30-35) and there is no way to play like that. This slowdown exists no matter if I set native resolution, 2x, or even 1920x1080 (by the way, the framerate is mainly the same in each of those 3 settings ... ).
I tried different options in GSdx or in Emulation Settings, but there is no way to make the game work in normal speed.
My question is:
Is it possible somehow to fix this flickering while the VU is enabled, or if not, improve game speed while it's disabled? I've read some topics and I didn't find any solution. I think that there may not be any, but it's always good to ask.
Thanks in advance.
Reply

Sponsored links

#2
PC specs? PCSX2 settings? Plugin settings?

Try disbling other speedhacks while using the VU cycle stealing one but it's possible that speedhack is creating the glitch to begin with and that's why it gives so much better speed Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Intel Core i5 M450 2,4 GHz
4GB RAM
GeForce 330M (with 1 GB RAM)
Windows 7 64-bit

All emulation settings are set to defualt (I only try different speedhacks).
In GSdx settings I've got:
Direct3D10 Hardware
No Interlacing
2x scaling
Texture filtering
Alpha Hack
Offset Hack
(Those 2 hacks help with blur that I get with resolution higher than native and with fog)

It's curious that among all speedhacks only VU cycle stealing gives me nice speed.
When I disable all speedhacks I've got 25-30 fps and the game is slow.
When I enable EE Cyclerate to 3, INTC Spin Detection, Wait Loop Detection and all micro VU hacks I get 30-35 fps and the game is still slow.
With all speedhacks disabled, only with VU cycle stealing set to 3, I get 45-50 fps, the game is in good speed, but the main character is flickering...
(With all speedhacks on and with higher base framerate I get even 70 fps)

PS. The higher VU cycle stealing I set, the faster Kratos flickers (but the game is playable with VU set to 2 or higher).
Reply
#4
it is necessary to speed hack 2, 1 most of the time for games that need it but it often create instability but a dal to 2.4 ghz it seems a bit low oc to 3.4 ghz that would be much better

I also have problems with flickering but it's happening to the image if not for the games without speed hack for me ffx has more problems with his hand when

I read that round zero mode can create instability in pass 2 in positive and zero flush off but I won that little pause stability problems like flickering of personal rog galaxy, but it is the only home

http://img534.imageshack.us/img534/3875/95422227.png
i5 750 4.3 ghz
noctua nh-d14
toxic 5850 x 2
asus sabertooth
2x2 gb ddr3 g-skill pc 12800
corsair 650 tx
seagate 1 tb raid 0
Reply




Users browsing this thread: 1 Guest(s)