Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of war 2 opengl scaling glitch
#1
When i try to change resolution with opengl hardware, i get this weird chromatic aberration effect on anti-aliased edges. When i play in native resolution everything is fine, and with custom resolution i get ghostly effect, which disappears, together with fog and shadows if i set aggressive CRC. 
Is there a way to get full hd resolution with fog and shadows, and without green aliasing?
My specs are:
gtx 970
amd FX 8370 (4.2 GHz)
Windows 10


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Try half pixel offset
Reply
#3
Half pixel offset doesn't work with custom resolution.
Reply
#4
Then don't use Custom Resolution Wink Use the Native x# scaling

Seriously CR is the bane of our lives.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Yes, it won't work. it isn't coded to work at custom resolutions, you should try using native scaling resolutions. (2x,3x...)
Reply
#6
Otherwise you can disable depth hardware emulation.
Reply
#7
When i use scaling i get green aliasing, when i disable depth hardware i lose shadows and fog. I found that CRT hack causes this green effect, when i set it to none, minimal or partial. When i set it to full or agressive i lose effects.
Reply
#8
Normally you need
* accurate blending to high
* CRC to partial
* upscaling resolution xN
* half pixel offset hack

The "rainbow" effect is a bad interpolation of the depth buffer which is used to compute shadows/fog. CRC will disable all those draw calls to rendering is "smoother"
Reply
#9
I set everything exactly as you said, so the only way to get a rid of rainbow is to disable that shadows/fog with crc? At least i have bloom now.
Reply
#10
Did you enable VU cycle stealing?

Could generate me a gs dump http://forums.pcsx2.net/Thread-How-to-cr...er-GS-dump ?
Reply




Users browsing this thread: 1 Guest(s)