Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 3 Help
#1
Ok, so im trying to run GT3, i own the actual game and it works great but my ps2 broke so now im trying to run it on my pc. Heres my pc specs

i7 950 3.07 ghz
6 GB DDR3-1600
gts 450 1 GB GDDR5
Win 7 64 bit Ultimate

I have the latest version of PCSX2 and my current settings are
GS plugin - GSdx 4600 (MSVC 15.0, SSE41)
SPU2-x for audio
on the GS settings i have these settings
Direct3d11 (hardware)
resolution at either 1024x768 all the way to 1920x1200

the game runs pretty decent, but when i start a race i get about 30fps and get small lag spikes. i read somewhere that this game is beefy but most posts are from a year or 2 ago. i saw some videos of people running it with core 2 duos with constat 110 fps. what settings should i have to get maximum FPS for this game? any help is appreciated Smile

-matt
Reply

Sponsored links

#2
Applied any Speedhacks?
Don't believe every video you see. They're too easy to fake.
And, yeah, it will be slower when a race starts (more cars on-screen).
Reply
#3
hm. not sure if theres an option for speed hacks with the gs plugin im using

EDIT - found the option in emulator settings

But what kind of fps should i be getting with my current pc specs?
Reply
#4
the speed hacks helped. normally when a race starts id get about 30 fps. now im getting 50. when in the race, i get a mostly 60 fps and drops to 52 fps which isnt bad. just sounds weird when the music is playing and slows a bit heh.. for the speedhacks here are the settings i have so please let me know if i should change them

EE Cyclerate at 2
VU Cycle Stealing at 1
Enable INTC Spin Detection is Checked
Enable Wait loop Detection Checked
Enable Fast CDVD UN-Checked
mVU Flag Hack Checked
mVU Block Hack UN-Checked

ALSO in the EE/IOP settings. should teh EE/FPU Advanced Recomplier options be set to chop/zero which is where it was when i installed PCSX2. thanks again for the help Smile
Reply
#5
I can't be too accurate, mostly since it can slow down quite tremendously when several cars are on-screen. You should be able to hit full speed when no cars are present, though. I believe I did back when I bothered trying that game on my C2D 2.8Ghz, but it was clearly not enough. IIRC, I saw single digit FPS for a moment when a huge pack of cars went by (and I was spun-out in the grass. lol), but that was revisions ago, too...


You should rarely need to mess with the EE/IOP and VUs, but it depends on the game. I don't think it's necessary with this one.

You seem to have the right idea with the Speedhacks, though. Start with the [Recommended] and experiment with the EE and/or VU sliders. Most times they'll improve FPS, but sometimes they can start to "break" some games. Sometimes both can be pushed to the max, other times a bit more modestly. In some cases, one may prove to be trouble if used at all.

Just try different amounts of one, the other, or both with each different game you try. Get the highest FPS you can manage, just beware that sometimes you can get an unusually high "fake FPS" reading when using hacks excessively. Watch out for that, and pay attention to how the gameplay truely feels. Smile
Reply
#6
Try setting the VU recompiler to SuperVU and reducing the EE/VU clamps to 'none', should help a bit with the remaining slowdowns.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
well i did what you said Shadow Lady and that totaly helped my FPS. but now im getting weird graphic issues. and VU settings you wanted me to change both VU0 and VU1 from 'microVU recompiler' to 'superVU recompiler [legacy]' correct? the flags kinda look long and textures on screen are sorta distorted.
Does it matter if i use Native resolution? or is custom better? and if my screen is fullscreen, will the fps change if i change it to full screen windowed mode? since i cant see the FPS when its full screen
Reply
#8
changed those VU settings back to normal and fixed the graphics issue. i think i have the "right" settings. i get a constant 59 fps but drops to 45 every once in a while.
Reply
#9
You don't need to stay at native resolution. Your GPU is good enough for more.
Try 2x scaling, or a custom of 1024x1024. You could probably push it higher, but it will start to affect FPS eventually.

Full-screen typically doesn't reduce the FPS, especially on a system that can rightfully handle PCSX2 well on a general basis (like yours). Smile
Reply
#10
ok awesome. yea i put it to 2x scaling and the lowest my fps got was about 54? which isnt bad i hope haha.. thanks for all the help everyone Smile the only slight erk i have now with the game is it gets all jittery sorta, but i can almost fix it with the interlacing option. so im pretty much a happy camper now haha

EDIT - the 1024x1024 resolution works like a charm Smile now if i can only get rid of the fuzzyness / fidgity haha
Reply




Users browsing this thread: 1 Guest(s)