Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 Help!
#1
So I got the PCSX2 0.9.8 running just for GT4! Got it set up and booted the disc. Seems that my running speed is directly linked to the FPS speed, and when it drops down to about 30 it feels like someone has slowed the game down, much like dragging your finger on an old record player.

Any insight on this?

Dual core 3.2g intel
Radeon HD4650
4GB ram
Win7
Reply

Sponsored links

#2
Hi, thanks for asking that question. While it might not be obvious when first thinking about it; the game's speed is set to the FPS of the game (~60 for NTSC regions, 50 for PAL regions) to avoid tearing on a TV screen (Vsync). Unlike PC games, PS2 games are made knowing exactly how much power the PS2 has, so the game does not keep full speed if the game dips below 60/50 FPS. So, an NTSC game running at 30 FPS will effectively run the game at 50% speed.


Now - as for helping you reach full speed, what do the EE%/GS% numbers at the top of your emulation window when you get these slowdown say?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
overclock your CPU.
3.2 ghz won't be enough for this VERY demanding game.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
When it really starts to lag, EE is at 50 to 65 and GS is at 18 to 30
Not sure on how to overclock just yet. My brother is more tech savvy than I am.
Reply
#5
Are you playing on native resolution?

Also, are you using any speedhacks?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#6
(08-16-2011, 03:54 AM)MyDreamName Wrote: Are you playing on native resolution?

The windowed resolution is 640x448. also the screen seems to be "bouncing" up and down a row of pixels, if that makes any sense?

No speedhacks.

jesalvein, I used to have the same processor.
Would this help any>?


EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
Reply
#7
That's not your current resolution; that's just the default resolution of the game.

Please go into Config>Video>Plugin Settings and make sure the "Native" box is checked, and then see what the numbers are when you get slowdowns. It is still most likely that your CPU is the bottleneck; racing games on the PS2 are the most CPU-intensive, and GT4 is no exception.

Also, the "bouncing" effect on games can be removed by using the Bob bff/tff interlacing. This can be set on the video plugin window or just by pressing F5 while the emulation window is active to switch through interlacing modes until you get to that mode.

Quote:Would this help any>?


EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400

This is normal activity that happens when certain files can't be found; it should have NO EFFECT at all on your gameplay though.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#8
(08-16-2011, 03:48 AM)jesalvein Wrote: overclock your CPU.
3.2 ghz won't be enough for this VERY demanding game.

random question - cause I'd like to know, I don't have the game. maybe... not yet. Wink

what's the demanding parts of this game? the macro VU0 physics? the texture uploads? or the poly count on VU1 (how many cars per VU program)? or maybe all of that?!
Reply
#9
Gotta tick all the speedhack boxes and play in native res. You should get over 60fps then
Reply
#10
(08-16-2011, 04:01 AM)MyDreamName Wrote: That's not your current resolution; that's just the default resolution of the game.

Please go into Config>Video>Plugin Settings and make sure the "Native" box is checked, and then see what the numbers are when you get slowdowns. It is still most likely that your CPU is the bottleneck; racing games on the PS2 are the most CPU-intensive, and GT4 is no exception.

Also, the "bouncing" effect on games can be removed by using the Bob bff/tff interlacing. This can be set on the video plugin window or just by pressing F5 while the emulation window is active to switch through interlacing modes until you get to that mode.


This is normal activity that happens when certain files can't be found; it should have NO EFFECT at all on your gameplay though.

Alright, the native box was unchecked and I checked it. Pushing F5 until it was under Frame mode got rid of the bounce.

I go to the B-1 License test in the game (where it is really slow) and it is showing

FPS: 60.09
EE: 67%
GS: 36%
UI: 0%
Reply




Users browsing this thread: 1 Guest(s)