Thread Rating:
  • 20 Vote(s) - 3.8 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 (NTSC) is playable. [HOWTO] Best config to enjoy it.
#1
Well in case some people doubted about it, maybe even the devs, I've just "finished" GT4 (NTSC version). I use quotes because I'm not done with the game yet, but I finished the main path in GT4 Gran Turismo mode.

It means I've played from the opening until the ending movie that can be viewed after having completed Beginner and Professional events. There are still a lot of championships I will continue to play but they are "optional". I have already completed a lot of them, and I don't think the remaining ones will hang, other than a located GSdx crash like I've already seen times to times but it can be bypassed by switching to ZeroGS at this moment.

I don't know if the game can be classified as "fully playable" because there is a lot of config "tuning" to do with the emu and the game itself but I can confirm the game can be finished at this state of the emulator. Smile

Attached some screenshots to confirm this Wink

For information, the last movie runs perfect, it's just that after that it will try to run the nasty opening movie that will hang. To bypass it, just see the end movie, and then load a savestate made at the end of the last race and press enter to skip it, it will come back to the main menu and unlock the last events. Smile I'll let you discover the last car reward, but it rocks Tongue

To sum up, the main things to know in order to have the best experience for NTSC version are the following :

- To fix the graphical glitches in the game menus (first letters missing etc) put PCSX2 VU clamp mode to Extra (in Advanced options). Keep other advanced options to default value.
- To fix the SPS (Spikey Polygon Syndrome, aka all the vertical lines / garbage appearing on the screen) at the beginning of the races, go to picture quality options in the game and put the brightness to 0.
- To fix the crashes at the beginning of the races versus IA, go to screen options and activate the 480p progressive mode in Video output.
- To fix the screen shaking effect, go to GSdx options in PCSX2 menu and change the interlace mode to "Bob tff".
- To fix crashes in game, during licences especially and some races, make a savestate (make sstates often, to prevent for example that crashes in a middle of a champ will result in making the whole champ again..), and switch to ZeroGS, that's a GSdx bug.
- To fix the crashes even after having verified the previous points, if you play with GSdx DX10 version, in the current version it just crashes if you try an internal resolution above 1024*1024. With DX9, you can play at whatever internal res you want.
- To fix the crash at the opening movie when you launch the game, just DL the patch anorexic posted in this thread : http://forums.pcsx2.net/thread-4375-page-3.html and put it in your PCSX2 patch folder. Then launch the game, and go to the game options, "Misc" options and deactivate opening movie, and activate the game autosave. You won't be blocked again. Wink
- Concerning the speedhacks, I've played the game with EE and IOP X2 ones, INTC and WaitCycles sync hacks activated and they are stable and give the best speed for me.

For information, I've played GT4 since a lot of revisions, I began the game around 1 month ago so before 0.9.6 release, and I finished it at svn rev746 (loaded a sstate at rev765 to make screenshots and it was also ok). It can be useful to know that in case of regression in the future.

*** Known issues ***

- GSdx crashes in licences trials and races (located)
- Big slowdowns when there are a lot of light sources on the screen, personally that means a 20 FPS drop, for some others it means a crash of the game. Tested a lot of GSdx versions, but that's the same, seems to be an emu related problem. If the devs want to check it rapidly, the most easy and obvious way is with the George V Rally race, which has enormous number of lights everywhere, that's a race that I played in slow motion personally xD
- Be aware on the savestates you make. GT4 autosave doesn't like them because it will autosave each time you buy a tuning equipment, change car, win a champ etc.. So make a sstate only on races, not before buying a piece of equipment to test it for example, because if the game tries to save the game that wasn't in the previous state it knows it will refuse to save the game. That can mean a lot of hours lost if badly done because you won't be able to switch your car for example..
--> I fixed the save problem by deleting the savestates files located in PCSX2 directory/sstates folder. After that, the game has been able to save correctly.
- The "Japan championship" in Japanese events does not seem to be correctly completable. For me it just hanged at the end of the last race at the moment of the reward reception. Tried a lot of things but no way. To bypass it, I abandoned the race, I had enough points to win the champ and that was fine. If you want to win the last race, you can try it alone after the champ so no problem.
- The Dive replay mode is not working correctly (accessible during replay with the "square" button). It shows SPS/garbage on the screen.

*** Minimum reqs to enjoy the game ***

- The game is VERY demanding, and if you want to play at a normal speed (60 FPS) a 3.5-3.6 Ghz processor as a minimum will be required. That won't prevent the slowdowns on some specific cases (lights, races by nights etc). An average graphic card will be ok.

Anyway, this thread is there to sum up the way to play GT4 the best and to avoid the problems, and because a lot of people are asking the same questions so I wanted to answer most of them here. I know a lot of people wants to play it so I hope it will help you guys, because the game deserves it !

Enjoy Tongue
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64
Reply

Sponsored links

#2
Thanks for doing this. I have found it to be playable even on my 3ghz athlon x2. I get about 45 fps but with the 480p mode it only seems to want 30 fps for full speed.

Did you have a problem with random textures in the roadway and then as you approached them they would disappear?
Reply
#3
Did you have a problem with random textures in the roadway and then as you approached them they would disappear? - - To fix the graphical glitches in the game menus (first letters missing etc) put PCSX2 VU clamp mode to Extra (in Advanced options). Keep other advanced options to default value.
Smile
Reply
#4
Does this config work for the PAL version?
Reply
#5
(03-13-2009, 10:19 PM)Frumpy Wrote: Did you have a problem with random textures in the roadway and then as you approached them they would disappear? - - To fix the graphical glitches in the game menus (first letters missing etc) put PCSX2 VU clamp mode to Extra (in Advanced options). Keep other advanced options to default value.
Smile

That only fixes the graphical glitches in the menus, what I'm describing happens during the race. NM my bad didn't see the other clamp mode, all fixed.
Reply
#6
(03-13-2009, 09:55 PM)Jules Wrote: Did you have a problem with random textures in the roadway and then as you approached them they would disappear?

I forgot to mention it, but yes I have this problem too, shadows/textures that disappear on the road, don't know where it's coming from, maybe GSdx but I didn't find a solution yet :'( If anyone knows how to fix it it would be great ! Tongue I just made with it since then, but that's kinda ugly sometimes Sad

Quote:Does this config work for the PAL version?

No, that's why I mentioned only NTSC version. The main problem for PAL version is the non existing 480p mode so I don't know but it's highly probable that the races vs AI will still crash until a fix for PAL version.

EDIT: So you found the solution for the texture problem with the clamp modes Jules ? Tongue What was wrong ?
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64
Reply
#7
I had originally only set EE recs options clamp mode to Extra+Preserve sign and that cleared up the menus. I went back and changed VU recs clamp mode to Extra and the textures in the road went away.
Reply
#8
(03-14-2009, 11:32 PM)Jules Wrote: I had originally only set EE recs options clamp mode to Extra+Preserve sign and that cleared up the menus. I went back and changed VU recs clamp mode to Extra and the textures in the road went away.

Well I don't know if we are talking of the same thing so I posted a screenshot of the bug I encounter. In fact the dark textures on the road disappear when I'm going above them. We can notice that in the screenshot the texture in front of my car is kinda cut.

I've tested with EE clamp mode to Extra+Preserve Sign & VU clamp mode to Extra but I still have this bug. Could you post some screenshots of your emu config please ? To see if I have it all right or not (GSdx plugin, speedhacks, advanced options..) Or if anyone else knows about this bug (that I encounter in other games, some textures in the floor disappearing..) I would like to know if I can fix this or not. Thanks Wink
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64
Reply
#9
Hi, I recently Captured this one on my rig, I wonder why there are sam FPS glitches, & it seems like there is a problem with Interlice, maybe all this is the Interlice problem?!?
Why during game (less), & during replay (often) game freezes on few seconds, but only when bunch of cars are around?!?

& during menu's, there are no background videos, & it looks all messy there, how to fix this?

Any suggestions? Tnx in advance...

Settings:
Winodws XP SP3 Pro
Mobo driver retail
Catalyst 9.2
Sound Driver kX v3541

- Pcsx2 svn r783

- GSdx 890 0.1.14 SSE2
D3D9 HW, PS3.0, Blendtff, 16:9, Native, Nloop Hack, Testure filtering, Log Z, FBA

- SPU2-X 1.1.0
Linear, DirectSound

- SSSPSX PAD Plugin Presure Mod 1.7.0
Real PSX Dual Shock Controller over LPT using psxp a020606c driver

- Linuz Iso CDVD 0.8.0
Using GT4 PAL Multi DVD iso ( SCES 51719 )

- Bios EU v2.00

- Cpu Config
EERec, VU0rec, VU1rec, MTGS, Frame Skip (52, 48, 1, 1)
- Speed Hacks
x3 Cycle Rate, INTC Sync Hack, IOP x2 Cycle Rate, WaitCycles Sync Hack
- Advanced Options
all default, EE Recs Options set on Extra + Preserve Sign, VU Recs Options set on Extra + Preserve Sign

Got 60-95% speed, most of the time on 75%

Here is a Video

http://www.youtube.com/watch?v=hFmvFnOIwCo

Cheers...
AMD FX-8350
4x 4GB DDR3 2400MHz
AMD Radeon R9 Fury X
Reply
#10
Here are some pictures

Cheers...
AMD FX-8350
4x 4GB DDR3 2400MHz
AMD Radeon R9 Fury X
Reply




Users browsing this thread: 1 Guest(s)