Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 flickering
#1
Hi,

I wanted to play GT4 again and since I don't have a TV at the moment I had to use PCSX2.

The Problem is after I made an iso file that the game isn't running.

It got flickering from the beginning and graphic bugs (a missing letter or in race green parts of the screen).

Game is the german platinum version.

Any ideas how I could fix it. I've tried to remake the iso several times with different programs, so its definitially not the iso. Also I've tried the different GPU plug-ins and older versions of PCSX which isn't working either. Also the flickering happens when I do full start of the iso at the start-animation of the PS2. So I guess it's not the game.
Reply

Sponsored links

#2
Please post:

Your PC specs
Your PCSX2 0.9.8 settings (screen shots are good)


You should consider just using Imgburn for ISO ripping. I highly recommend it, and nothing else.
Reply
#3
Did you make sure to go into the options while in the race to turn the brightness and contrast and such down to 0? This should get rid of the messed-up graphical errors in races.

I also got missing capital letters while in the hub world. I haven't done any specific testing, but I would guess it is my speedhacks messing with it.

Edit: Capital letters show up if you go into the "VUs" section of your emulation settings and set clamping to "Extra + Preserve Sign".

Hope this fixes your problems. Good luck!
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#4
(06-04-2011, 01:49 AM)MyDreamName Wrote: Did you make sure to go into the options while in the race to turn the brightness and contrast and such down to 0? This should get rid of the messed-up graphical errors in races.

I also got missing capital letters while in the hub world. I haven't done any specific testing, but I would guess it is my speedhacks messing with it.

Edit: Capital letters show up if you go into the "VUs" section of your emulation settings and set clamping to "Extra + Preserve Sign".

Hope this fixes your problems. Good luck!

Thanks for the effort, but it isn't working.




(06-04-2011, 12:21 AM)Rezard Wrote: Please post:

Your PC specs
Your PCSX2 0.9.8 settings (screen shots are good)


You should consider just using Imgburn for ISO ripping. I highly recommend it, and nothing else.

Settings are at default while I tried different settings and plugins, but none of them worked - so I put it back to default.


PC Specs I just copypaste it from the PCSX2 Log, since its easier Tongue


Quote:PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows XP Professional Service Pack 3 (build 2600)
Physical RAM = 3326 MB
CPU name = Intel® Core™2 Duo CPU E8400 @ 3.00GHz
Vendor/Model = GenuineIntel (stepping 06)
CPU speed = 2.999 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0008e3fd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Reserving memory for recompilers...

Loading plugins...
Binding GS : D:\Roms\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 5.1.2600 (Service Pack 3 3.0)
ATI Radeon HD 4800 Series (6.14.10.7119)
Binding PAD : D:\Roms\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : D:\Roms\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : D:\Roms\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : D:\Roms\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : D:\Roms\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : D:\Roms\PCSX2 0.9.8\Plugins\DEV9null.dll
Reply
#5
umm did you just load up pcsx2 then copy and paste the console window?

run the game, then copy and paste the cotents, or open the "emulog.txt" from the logs folder (make sure its the right one, date is a good indicator)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(06-04-2011, 03:11 PM)refraction Wrote: umm did you just load up pcsx2 then copy and paste the console window?

run the game, then copy and paste the cotents, or open the "emulog.txt" from the logs folder (make sure its the right one, date is a good indicator)

You mean this?


Quote:PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows XP Professional Service Pack 3 (build 2600)
Physical RAM = 3326 MB
CPU name = Intel® Core™2 Duo CPU E8400 @ 3.00GHz
Vendor/Model = GenuineIntel (stepping 06)
CPU speed = 2.999 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0008e3fd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Reserving memory for recompilers...

Loading plugins...
Binding GS : D:\Roms\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 5.1.2600 (Service Pack 3 3.0)
ATI Radeon HD 4800 Series (6.14.10.7119)
Binding PAD : D:\Roms\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : D:\Roms\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : D:\Roms\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : D:\Roms\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : D:\Roms\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : D:\Roms\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 276ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 5.1.2600 (Service Pack 3 3.0)
ATI Radeon HD 4800 Series (6.14.10.7119)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Dokumente und Einstellungen\Schulle\Desktop\GT4\Gran Turismo 4.iso
Image type = DVD
Fileparts = 1
isoFile: searching for layer1...
isoFile: loaded second layer from settings cache, sector=0x0018c180
* CDVD Disk Open: DVD, Double layer:
* * Track 1: Data (Mode 1) (2763936 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Dokumente und Einstellungen\Schulle\Eigene Dateien\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Dokumente und Einstellungen\Schulle\Eigene Dateien\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v02.00(14/06/2004) Console
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_517.19;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SCES_517.19;1) Game CRC = 0x44A61C8F, EntryPoint = 0x01000008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_517.19;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
Reply
#7
OK if u can overfclock your cpu to about 3.50ghz , cuz i dnt think it would be too much trouble for it lol. oh and clamping modes other than Normal will require more power from ur CPU. Usually if you have speed hacks activated, try unchecking the VUblock hack. its the second box on the right.
(OS:Win7_64bit ULTIMATE) (M4a88TD-M asus mobo)
[Processor:AMD AthlonII x4 645 3.720ghz(OC)Quadcore]
VideoCard-[ATIradeon5750(OC) 850mhz 2GB
RAM-[DDR3-4GB Matched RAM w/ Heat Spreaders]HYperX BLU
cpu-cooler- H60 closed loop water cooling.
Reply
#8
(06-04-2011, 10:31 PM)[pro]PCSX2 Wrote: OK if u can overfclock your cpu to about 3.50ghz , cuz i dnt think it would be too much trouble for it lol. oh and clamping modes other than Normal will require more power from ur CPU. Usually if you have speed hacks activated, try unchecking the VUblock hack. its the second box on the right.

CPU is at ~50-55 % working load. Speed hacks are obviously not activated, since I use the PCSX2 default settings. So I somehow doubt the CPU has not enough power.

Especially when I already ran half a year ago Final Fantasy X pretty smooth (except for like 3 spots in the game where it was a little bit slow) on version 0.9.6. But GT4 has the same problem on the 0.9.6 version.
Reply
#9
since everything is at default and ur getting flickering try changing your VU Roundmodes.
(OS:Win7_64bit ULTIMATE) (M4a88TD-M asus mobo)
[Processor:AMD AthlonII x4 645 3.720ghz(OC)Quadcore]
VideoCard-[ATIradeon5750(OC) 850mhz 2GB
RAM-[DDR3-4GB Matched RAM w/ Heat Spreaders]HYperX BLU
cpu-cooler- H60 closed loop water cooling.
Reply
#10
(06-05-2011, 12:18 AM)[pro]PCSX2 Wrote: since everything is at default and ur getting flickering try changing your VU Roundmodes.

That doesn't change anything. =(


btw I forget to descripe how this flickering is. The first screen on GT4 (some text about license) is running without flickernig but as soon as the next screen comes there are 2 kinds of flickering.

1. This one happens all the time. Its like the screen is heading up and down.

2. This flickering happens at times. It somewhat shades out a few things. Mostly only darkens but sometimes completely missing.
Reply




Users browsing this thread: 1 Guest(s)