Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Grandia 2 Graphical error
#1
Is there some way to fix the gray that appears on the ground?

see attached image. I tried several different settings, switched direct x version, sse2-4 but they don't seem to work.


Attached Files Thumbnail(s)
   
Windows 7 - Asus G73jh-a1 - 17-720qm @ 1.6 GHz (2.8 GHz)(2.4ghz)(1.73ghz) - ATI Mobility Radeon HD 5870 @ 700/1000 (sometimes oc to 800/1100) - 8 gig ram
Reply

Sponsored links

#2
bump

I'm actually noticing a few things. Take a look at this next image. When using a linear attack like this, for some reason, it hits everyone enemy on the screen when its not suppose to.

Should I put this in the bug report thread? Also, during certain scenes (especially cinemas), there are a lot of vertical lines on the screen which shouldn't be there.

edit - added image of vertical lines


Attached Files Thumbnail(s)
       
Windows 7 - Asus G73jh-a1 - 17-720qm @ 1.6 GHz (2.8 GHz)(2.4ghz)(1.73ghz) - ATI Mobility Radeon HD 5870 @ 700/1000 (sometimes oc to 800/1100) - 8 gig ram
Reply
#3
What cheats are you using? Are you using save states?

What non standard settings have you set? (speed hacks) Have you tried hitting F9 for software mode?
Cooler Master HAF X Full Tower
ASRock Z97 Extreme4
EVGA GeForce GTX 970 4GB
EVGA SuperNOVA 850W
Intel Core i5-4690K - OC'ed to 4.5GHz
G.SKILL Ripjaws X 8GB DDR3 1600
CORSAIR Hydro H105
Indigo Xtreme 115X-XS Metallic TIM
Windows 7 SP1 64-bit
PCSX2 1.4.0 unless otherwise specified
Reply
#4
I disabled all speed hacks to see if they were doing it while I was playing and nothing worked. I tried software mode too, doesn't seem to work. I tried changing the Advance Recompiler options, honestly I have no idea what those do but those seems to not help.

Interpreter just makes everything very slow. Tried Direct 11 and 9 hardware and software, tried enabling/disabling 8 bit texture., tried native

Seems nothing is working. I don't think I tried everything though.
Windows 7 - Asus G73jh-a1 - 17-720qm @ 1.6 GHz (2.8 GHz)(2.4ghz)(1.73ghz) - ATI Mobility Radeon HD 5870 @ 700/1000 (sometimes oc to 800/1100) - 8 gig ram
Reply
#5
If you tried all of that then there's nothing mroe you can do. its an compatibility problem with the emulator. You should fill out a bug report and the coders will add it to the huge ass list they have.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#6
Which version of the emulator are you using? If you check the compatibility list you will see that the game is playable on version 1.0.0 and if you are using an earlier version you won't get much help from here as earlier versions aren't supported since 1.0.0 is the current stable release. HAve you also tried using a newer SVN and seeing if that helps at all?

http://pcsx2.net/compatibility-list.html

http://pcsx2.net/download/development/svn.html
Reply
#7
this ^

Also you never answered the cheat question. while it likely wouldnt cause your graphical glitches, it could cause the issue where enemies not in line are damaged.

If you are using cheats, disable them to see if that fixes the issue.
Cooler Master HAF X Full Tower
ASRock Z97 Extreme4
EVGA GeForce GTX 970 4GB
EVGA SuperNOVA 850W
Intel Core i5-4690K - OC'ed to 4.5GHz
G.SKILL Ripjaws X 8GB DDR3 1600
CORSAIR Hydro H105
Indigo Xtreme 115X-XS Metallic TIM
Windows 7 SP1 64-bit
PCSX2 1.4.0 unless otherwise specified
Reply
#8
(07-30-2013, 11:29 AM)Topken Wrote: Which version of the emulator are you using? If you check the compatibility list you will see that the game is playable on version 1.0.0 and if you are using an earlier version you won't get much help from here as earlier versions aren't supported since 1.0.0 is the current stable release.

I'm using 1.0.0 r5350

Quote:HAve you also tried using a newer SVN and seeing if that helps at all?

http://pcsx2.net/compatibility-list.html

http://pcsx2.net/download/development/svn.html

No I haven't. I'll check this out.

(07-30-2013, 03:34 PM)jlwmanagement Wrote: this ^

Also you never answered the cheat question. while it likely wouldnt cause your graphical glitches, it could cause the issue where enemies not in line are damaged.

If you are using cheats, disable them to see if that fixes the issue.

No, I'm not using any cheats. Thanks for the help. I'll check out the SVN thing some time this week.
Windows 7 - Asus G73jh-a1 - 17-720qm @ 1.6 GHz (2.8 GHz)(2.4ghz)(1.73ghz) - ATI Mobility Radeon HD 5870 @ 700/1000 (sometimes oc to 800/1100) - 8 gig ram
Reply
#9
This bug isn't fixed yet, sorry.
The game has issues on the PS3 emulator as well btw, which hints at a lot of corner case floating point precission issues.
I'm not sure if we can ever totally fix this in the emu.
A cheat code that alters the camera angles a bit would prolly work though.
Reply
#10
(08-01-2013, 07:05 AM)rama Wrote: This bug isn't fixed yet, sorry.
The game has issues on the PS3 emulator as well btw, which hints at a lot of corner case floating point precission issues.
I'm not sure if we can ever totally fix this in the emu.
A cheat code that alters the camera angles a bit would prolly work though.

Had to look up floating points. So basically its the game developers fault for using it in the first place making it a difficult to go from ps2->computer causing all sorts of problems?
Windows 7 - Asus G73jh-a1 - 17-720qm @ 1.6 GHz (2.8 GHz)(2.4ghz)(1.73ghz) - ATI Mobility Radeon HD 5870 @ 700/1000 (sometimes oc to 800/1100) - 8 gig ram
Reply




Users browsing this thread: 1 Guest(s)