Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Grandia III Sound Beep/Screech
#1
During battles and what not, there are times when anyone attacks or casts a spell there's this high bitched beep, like when you press a button to long on a keyboard and it makes that high pitched noise.

I can't figure out how to fix it in my Audio and I've tried many of the Plugins for the Audio

Some Finer Details.

I've noticed that it happens whenever I attack something or get attack and it's always caused at the attack or during the battle intro (Where everyone runs in and then the battle starts)

It's making me wonder if theres a bad audio file or something in the game file or somethng.
Reply

Sponsored links

#2
I also have this issue, however it seems to only effect me while using my SPU2-X 1.4.0 audio plugin. If I switch to Peops SPU2 1.9 I lose the beeping but the audio does not stay in sync during a cut scene. Not sure which is worse.

Other then that the game plays great have near a constant 60 fps with no speed hacks on. Drops on occasion during the start of a cut scene or entering a new area, but eventually picks itself up.

If anyone knows a quick trick to fix either of those problems it would make me very happy.
Reply
#3
Try disabling "effects processing" and changing the synchronizing mode in SPU2-X.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
(11-26-2010, 12:04 AM)Shadow Lady Wrote: Try disabling "effects processing" and changing the synchronizing mode in SPU2-X.

thanks for the reply, Just did what you said, and in doing so Does remove the annoying beep from the game. Thanks. However it still seems to go out of sync in cut scenes where I can only manage a 40 fps, Perhaps I should look at certain speed hacks to counter this?
Reply
#5
What actually fixed it?
If it was the Async synchronizing mode then it's the effect that it has and yes you should try to find faster settings.

You could also try an older version of SPU2-X
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
(11-26-2010, 05:19 AM)Shadow Lady Wrote: What actually fixed it?
If it was the Async synchronizing mode then it's the effect that it has and yes you should try to find faster settings.

You could also try an older version of SPU2-X

sorry, took a few days to get back to here and reply.

Yes Async fixed the noise, however even with speedhacks I can not seem to match the audio and video in sync. eventually ill hit a spot in a cutscene where it goes a tad slower, and the audio doesnt care to slow down.

However I tested the noise a bit more and it seems to only happen near the beginning of the game, which is a little before and after reaching the casino. So as of now I am using no speed hacks and went back to recommended settings of SPU2-X, and everything is working great.
Reply
#7
The noise comes from the reverb buffers getting played when they shouldn't.
To fix it you'll need to disable effects processing.
(I know it does that but I had to make a tradeoff choice between the noise in G3 or several games not booting Wink )

When you use async mixing, the audio will go off-sync at times. Use timestretch to fix the sync (but live with slowing down audio).
Reply
#8
(12-02-2010, 02:45 PM)rama Wrote: The noise comes from the reverb buffers getting played when they shouldn't.
To fix it you'll need to disable effects processing.
(I know it does that but I had to make a tradeoff choice between the noise in G3 or several games not booting Wink )

When you use async mixing, the audio will go off-sync at times. Use timestretch to fix the sync (but live with slowing down audio).

thanks a lot, will do just that if I run into that problem again.

side note: thanks for the responses and keep up the good work, pcsx2 is looking great. I hope it continues to grow and prosper.
Reply




Users browsing this thread: 1 Guest(s)