Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphical Bug in Silent Hill 2 and 3 for 0.9.7 (DOES NOT OCCUR IN 0.9.6)
#1
Ok, I'm bashing my head in trying to figure out whats going wrong. Before I go into the problem I will go over the settings

I am using 0.9.7 build 3898

My OS is Windows 7 64 bit

Lilly Pad 0.10.0 3898

Controller being used Dualshock 3 with Motioninjoy controller
I have all API settings checked and the latest libusb installed
I have tested with ever combination of API settings checked and unchecked
I have tested with and without use analog whenever possible setting checked
I have tested sensitivity changes ranging from 1.0-5.0 on all directions
I have tested using Dpad only
I have also tested the SSPX Plugin
I have tested using the Keyboard as well with up down left and right mapped to WASD

Now, to my problem:
In Silent Hill 2 and 3 games *only* (does not affect other games such as Devil May Cry 2)Though its worse in 3 then it is in 2, 2 seems to cooperate a little better. To start the game is set to the 2D control scheme, which means that rotating the joy stick will make her walk in a circle instead of simply turning (3d scheme aka Tank Control) This means when I press down she will go toward the camera and when I press up she will go away from the camera. Hence my issue. Heather will NOT go toward the camera, she will go away from the camera until I attempt to turn her around, then she will be stuck.

When I attempt to move Heather (or James) she does not cooperate hardly at all. In some rooms she will rotate 360 degrees and will turn backward when I press down or up on the dpad or joystick, however in most cases, particularly in hallways she will NOT turn around when I press the down or up respectively, she will walk in a diagonal direction going toward the screen when I toy around enough with pressing left or right, but there is no discernible pattern as to which direction will make her go toward the screen. When I attempt to press down to turn her around it acts as if there is a barrier on the screen and won't let her continue toward the screen. She will in most cases go forward just fine until I attempt to turn her around, then she will only go left or right until I eventually use a diagonal and she will go forward either away from or toward the screen but will hit whatever wall is in that direction and I can just barely straighten her out because then half way through the screen she won't go toward the opposite direction left or right!. So basically, whenever I attempt to do any kind of rotation heather refuses to cooperate and I have to go in random diagonals to get her to turn around, which of course makes the game unplayable.

If ANYBODY has a suggestion I can use, preferably using the Dualshock 3 with Motioninjoy driver which works with EVERY game I have played other than this one I would be most appreciative.

Reply

Sponsored links

#2
I have determined this is not a control issue but a Graphical Issue, I just switched to 0.9.6 with the GSDX 890 SSE3 0.1.14 Plugin. With this configuration I have NO issues (aside from shadow bugs and things that are likely something with that plugin.)

I attempted to use this plug in with 0.9.7 builds but encountered the same issue. So it is definitely a build problem. I tried both 3878 and 3113 with this plugin and also tried toggling flush to zero on EE and VU off with no change. I have tried Native Res, turning off all hacks and nothing makes a difference, the only way I have been able to fix it was using the 0.9.6 build (fyi used the Lillypad controller plugin 2935 0.10.0 which I also tested within 0.9.7 with no change)

Using default settings in 0.9.6 with the above plugin fixed my issue (and also does not have the problem of squeezing the game to the top of the screen) However I fear the game may not be playable on this build as I recall so I would like to know, with this new information if there is any configuration for 0.9.7 that would fix the issue and allow the game to be as playable character control wise as it is in 0.9.6?

(FYI I have posted a Bug Report for this since its not plugin related but if anyone has answers feel free to post in either thread)
Reply




Users browsing this thread: 1 Guest(s)