Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphical Glitches, Config?
#1
Hey there, I realize that the PCSX2 emulator isn't perfect by any means, so I accept a little graphical glitch here and there, like grey floors in Grandia 2 and Black in Shadow Hearts Covenant, but, it's when I go to youtube and see other people emulating games perfectly with no glitches, and it makes me wonder if I have my config correct.

I use r1888.

http://i32.photobucket.com/albums/d27/Yu...1261491620

Sorry about the big picture, I just want to make sure that there isn't some kind of secret option I should've checked but I haven't :X

Thanks.
[Image: 2212125.png]
| XFX HD6950 2048MB @ 900/1400 |
Reply

Sponsored links

#2
2 big things: Don't enable special game fixes for games that don't need it. You have to manually turn those special hacks on when you run those specific games, leaving them on will likely break or cause all sorts of weirdness for other games.

The other is, have you tried DX10 mode (assuming of course that you have windows vista or 7) as it's generally faster AND fixes a lot of graphics bugs. You can also try enabling microVU0 and 1 as they often times fix geometry and graphic bugs as well.
[Image: 2748844.png]
Reply
#3
Well I have Win7 on another partition I guess I'll try it out sometime later.

I tried .Hack GU and it actually worked faster after doing everything you said. Thanks.

EDIT -

I tried it on DX11 on Win7 assuming that DX11 is the same as DX10, and it was pretty much the same, I didn't do that much of a thorough test though.
[Image: 2212125.png]
| XFX HD6950 2048MB @ 900/1400 |
Reply
#4
Don't use DX11 it's in alpha stages and will cause crashes.
Use DX10 hardware in GSdx and disable 8-bit textures. To get a nicer, high res output uncheck the native box in GSdx and set a resolution there like 1280x768 (or whatever your graphics card can handle). That will have a similar effect to the 'AA' in ZeroGS (which is practically the same thing just named differently) but without the huge slowdowns
[Image: newsig.jpg]
Reply
#5
Well I tried that before, it seems to be the same as DX11 and DX9, I didn't disable 8bit textures though; and unticking native for .Hack GU makes it look much nicer with AA but it makes this really weird brown filter show up, and I can see my character's head slightly above him, kind of like having a bad reception on an old TV. "Ghosting" is what I think it's called.

Thing is, a portion at the bottom of the screen is fine, it's just the other 80%. Any ideas?
[Image: 2212125.png]
| XFX HD6950 2048MB @ 900/1400 |
Reply
#6
The ghosting in .hack//gu is fixed by using gsdx revision 1398 or waiting till beta 0.9.7 is out with the new GSDX with the scaling option. Either way fixes it.
[Image: 2748844.png]
Reply
#7
ah, nice. I don't really use PCSX2 to seriously play games and finish them, since I have a PS2 here and I've just ordered Persona 4, Suikoden 5/Tactics and Dark Chronicle (Dark Cloud 2), I consider the program more of a demonstration of technology and coding. Which I find interesting.

But anyway, thanks for the tip. The only way to play G.U in the UK is by using an emulator, since it isn't in PAL, only NTSC Sad
[Image: 2212125.png]
| XFX HD6950 2048MB @ 900/1400 |
Reply




Users browsing this thread: 1 Guest(s)