Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphics Trouble
#1
Hey there. So I just got into PCSX2 because I wanted to play all my old PS2 games. I still have a bunch. Anyway, I got it to work and can run my games, but I'm suffering from "lag" per-say, graphical downgrades and discoloration...I'll show a picture of what I mean. Can someone tell me how to post a picture on this thread? I keep trying to in the attachments, but it exceeds the maximum size.

I definitely have the system to handle these games I just don't know how to fix this problem.


System:
i5 quad-core
GTX 680
3 TB HD
16GB RAM

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
System

CPU: I5 3570k
Mobo: Asus p8z77-v pro
GPU: NVIDIA Geforce 680 GTX
RAM: 16 GB


Version of PCSX2 1.2.1

Graphic Settings
   

Ratchet and Clank is the first and only game I tried. All games are off the original disks/DVD
#4
first off don't tick everything. Just Texture Filtering (make it a tick too) and nothing else.

Also you have your screen resolutions the wrong way around, it should be 1920x1080.

Thirdly Ratchet and Clank looks a mess in hardware mode so it needs to be played in Software Mode, which will be in the original PS2 resolution, but the textures will be right. Just make sure you set "Extra renderer threads" to 3. You will probably need some speedhacks or overclock your cpu to get a decent speed though.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#5
Yeah, enable all recommended speedhacks, MTVU, and set the EE Cyclerate hack to either 2 or 3.

That will give you around 45-60fps.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#6
Thanks all. That fixed it.
#7
(07-29-2014, 01:20 AM)Tagger1911 Wrote: Thanks all. That fixed it.

You're welcome man. Smile
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#8
Hi, i have question with MTVU.my PCSX2 1.2.1 (r5875) APPCRASH/no response if enable MTVU.
CPU:
Intel® Core™ i5-3470 CPU @ 3.20GHz
#9
(07-29-2014, 09:31 AM)sammicom Wrote: Hi, i have question with MTVU.my PCSX2 1.2.1 (r5875) APPCRASH/no response if enable MTVU.
CPU:
Intel® Core™ i5-3470 CPU @ 3.20GHz

Open your own thread instead of rudely hijacking someone else's.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]




Users browsing this thread: 1 Guest(s)