Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphics issues in linux
#1
Just started using Pcsx2 after an extremely pleasant experience in Windows. Regular version and beta version binaries wouldn't start. They gave me some error about glew not being installed, even though it was. I compiled my own version from source, so right now this issue is under r1163 (although it's recurred through r1156, when I started using the Linux version). All games show up like the attached image (should be the Funimation logo, I believe.) Not quite sure what it is, but to my untrained eye, it doesn't look like a bug. Looks like I have some setting enabled that I shouldn't. Any ideas?


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
it's not something that can be easily fixed, but it has been getting better (I have been using the linux side for a while now)
Reply
#3
(05-10-2009, 12:20 AM)Saiki Wrote: it's not something that can be easily fixed, but it has been getting better (I have been using the linux side for a while now)

Oh, so it's not just me? Alright. I thought it was maybe some kind of texture filtering that I left on, maybe even compiz.
Reply
#4
(05-10-2009, 12:24 AM)zatara214 Wrote:
(05-10-2009, 12:20 AM)Saiki Wrote: it's not something that can be easily fixed, but it has been getting better (I have been using the linux side for a while now)

Oh, so it's not just me? Alright. I thought it was maybe some kind of texture filtering that I left on, maybe even compiz.

nope, it's the plugin
Reply
#5
Actually, IIRC, it's your antialiasing settings in the nvidia control panel messing it up...
Reply
#6
(05-10-2009, 02:19 AM)arcum42 Wrote: Actually, IIRC, it's your antialiasing settings in the nvidia control panel messing it up...
I don't have anything set up for AA in my install and get the same thing with some games (not tried any of the DB-universe ones though)
Reply
#7
If you look at the way everything's blurred and boxy in the example image, though, I've seen that before.

If you go in the "Nvidia X Server Settings" control panel, and go under Antialiasing Settings, there's a checkbox for Anisotropic Filtering, and having that checked will cause exactly that visual problem on all games. the main reason I remember is I accidentally checked that once and forgot about it, and it took me forever to figure out what was messing up pcsx2's graphics... Smile

If you've got an Nvidia card, try enabling that and start up a game, and you'll see what I mean...

This would be on all games, not just some of them, though. Messed up graphics on some games can very from your antialias settings in ZeroGL/ZZogl, bilinear filtering, forgetting that one of the hacks is on, or just that that games doesn't work well with the plugin, or even with pcsx2.
Reply
#8
(05-10-2009, 02:31 AM)arcum42 Wrote: If you look at the way everything's blurred and boxy in the example image, though, I've seen that before.

If you go in the "Nvidia X Server Settings" control panel, and go under Antialiasing Settings, there's a checkbox for Anisotropic Filtering, and having that checked will cause exactly that visual problem on all games. the main reason I remember is I accidentally checked that once and forgot about it, and it took me forever to figure out what was messing up pcsx2's graphics... Smile

If you've got an Nvidia card, try enabling that and start up a game, and you'll see what I mean...

This would be on all games, not just some of them, though. Messed up graphics on some games can very from your antialias settings in ZeroGL/ZZogl, bilinear filtering, forgetting that one of the hacks is on, or just that that games doesn't work well with the plugin, or even with pcsx2.

Yeah, that's exactly what I thought it was at first. But in doing this, I find that I still get the same problem. Since you say this, though, I think I'll snoop around to see if there are more hidden settings set to AF than just the nvidia-settings ones.
Reply
#9
might be one in display, depending on your flavor
Reply




Users browsing this thread: 1 Guest(s)