Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gray box in Gauntlet SS
#1
problem: there is always a gray box in the upper left while playing gauntlet 7 sorrows.
[Image: gsdx_20151113095424.jpg]
The game plays great other than this nuisance.  I just thought I would ask if anyone knows of a way to get rid of the gray box?

The gray box does not show up when using a software rendering, only hardware rendering.

OS: Windows 8.1
Video: NVidia GTX750 - latest drivers.
PCSX2 version: 1.2.1.  I also compiled the latest from GitHub and tried that.  same result.
Video plugin: GSdx.  I tried several versions. Different SSE levels.

I tried many, many plugin and emulation settings. 
some of them were:

D3D9 & D3D11
Native resolution and 2x res
Emu Preset to Safest
Disabled all speed hacks.
Disabled MTVU
Frame skipping constant 2
Reply

Sponsored links

#2
looks similar to the MGS2 texture cache bug : https://github.com/PCSX2/pcsx2/issues/905

could you check whether the issue is triggered on Opengl (hardware mode) with hardware depth and blending unit accuracy set to different levels on the latest development build : http://pcsx2.net/download/development/git.html
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
looks like that bug is your saving grace Tongue That top left texture should be repeated across the entire screen, so you wouldn't be able to see it, so you got lucky! Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
ssakash,
I got the latest and compiled. I set the renderer to OpenGL Hardware and there is no gray box.

I tried these settings:

hardware depth: off
Blending unit accuracy: Basic
Result: good. No gray box

hardware depth: on
Blending unit accuracy: Basic
Result: good. No gray box

hardware depth: on
Blending unit accuracy: High
Result: good. No gray box

hardware depth: off
Blending unit accuracy: High
Result: good. No gray box
Reply
#5
Thanks for the tests ! glad that it's resolved for you. Smile

@refraction

more DX stuffs for you to handle Tongue2
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
[quote pid='491593' dateline='1447432419']
It looks like I spoke to soon.  I didn't notice this until I went full screen.  Very strange.  That box area just stays brighter.
This is very minor and playable at this point but I can test some more if you need.

[Image: g2.jpg]
[/quote]
Reply
#7
Feel free to also make a bug report with comparison to the intended results, more tests are always welcome. Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
After playing around more I found a solution. Posting in case anyone runs across this thread with the same problem.

Video Plugin Settings:
Enable HW Hacks
Configure Hacks
Set Skipdraw: 1
Reply
#9
Yeah the brighter bit is how it should look accurately (youll probably notice software mode is the same as that corner block)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(11-13-2015, 09:18 PM)refraction Wrote: Yeah the brighter bit is how it should look accurately (youll probably notice software mode is the same as that corner block)

ok I tested that again.
If the renderer is set to either OpenGL (software) or Direct3D (software) the problem does not exist.  There is no box at all in either of those modes.
Reply




Users browsing this thread: 1 Guest(s)