Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Growlanser: Heritage of War issue
#1
Hello, forum to which I am new to. That said I'm fairly new to this emulator and am having a bit of an issue with Growlanser 5. 3 has it's issues like not being able to save to a memory card and the 25% chance to freeze upon a mission completion. Whether 2 works is beyond me because I beat that game many years ago. Anyways, I digress...

The problem is that it would seem that Heritage of War is having issues recognizing the layers of the game. I'll post examples below but to describe it bluntly, all models will be over every piece of foreground at all times; trees, benches, fences, whatever. Among that some layers like water will overlap over things they are not supposed to and other such things.

I tweaked with a bit of settings to try and get it working and did by swapping over to Direct3D9 (Software) instead of Hardware. Normally that would be fine, it's not like Heritage of war is a very strenuous game even simply with software but there are exceptions within the game that can make it a bit annoying. Like say for example how early on in the forest area a fog rolls over the screen and takes my nice 60 FPS down to 22ish. Prolonging battles to a silly degree.

If there is some setting or method which could remedy this issue by say allowing me to fix this layering problem while in hardware mode it would be much appreciated.

--
Some Emulator settings I'm using:
Version: r4942 (I realize that's 2 versions behind. (I think?) Quite impressive that this emulator updates so fast, I downloaded that version yesterday)
Video plugin: Using SSE41 (Not sure if that's right or not.)
Tried with and without speedhacks, didn't really help in fixing the graphic problem and I'm not sure how much it would really help me in software mode.

Screenshot examples:
[Image: pcsx2-r49422011-10-2420-10-25-95.jpg]
[Image: pcsx2-r49422011-10-2422-32-47-89.jpg]

My CPU Specs:
Windows XP Professional (5.1, Build 2600) Service Pack 3
Intel® Core™2 Quad CPU Q9400 @ 2.66GHz (4 CPUs)
3326MB RAM
NVIDIA GeForce GTX 460
Realtek HD Audio output

Sponsored links

#2
Hmm. don't know if the GSDX Hacks may fix it or skip the layer.

OK change the GSDX.ini (it can be in My Documents/pcsx2/inis Or in the Inis/ Folder where you have installed PCSX2. If you have the portable.ini in you pcsx2 folder then it will be in the Inis/ Folder there)

Open GSDX.ini and change it to

GSDx.ini Wrote:allowhacks=1

While configuring you GSDX, try the Alpha Hack(If it works). OR try the SkipDraw hack.
SkipDraw skips the drawing of a selected layer.
Try various number and see if someone works.
[Image: recodersignature2.png]
#3
Mmm... unless I blatantly screwed up editing the ini, (Quite positive I didn't) I didn't see any changes within the game. Still walking over trees like a boss.

Thanks of course for your input and I'll continue to tinker around with what you said on the chance that having some specific number might fix my issue.
#4
If you could try at somebody's pc with windows vista/7 in DX10/11 mode maybe it would give you hope for the future when you upgrade your own OS, as DX10/11 usually fixes alot of such issues seen in DX9.
Through maybe that's not the case here;P, if you use upscaling in hardware and it doesn't happen in software, try native res, I saw like only one game having similar problem till now myself and it was clearly an upscale bug.
#5
(10-25-2011, 05:55 PM)miseru99 Wrote: If you could try at somebody's pc with windows vista/7 in DX10/11 mode maybe it would give you hope for the future when you upgrade your own OS, as DX10/11 usually fixes alot of such issues seen in DX9.
Through maybe that's not the case here;P, if you use upscaling in hardware and it doesn't happen in software, try native res, I saw like only one game having similar problem till now myself and it was clearly an upscale bug.

I don't plan on updating my OS for quite a long while so I won't even bother checking on a different PC. (That and the other PC that has windows Vista is also a piece of crap.)

Far as scaling being the issue I can assure that it is not, as I already tweaked that. I always play in Native resolution -- though that second screenshot was in an upscaled resolution but that's while I was testing settings.
#6
This will probably be fixed by dx10 hardware rendering.
Dx9 has limitations that are hard to get around, especially with Z ordering.
#7
This issue still persists with the latest pcsx2 version.

I've already tried the suggestions in this topic.
Intel core 2 duo E8400 3.00 GHz
4gb ram
ATI Radeon HD 4870
Windows 7
#8
already tried with the latest version pcsx2 and svn and still got the same problem like Skiegh
is there any solution....?
Pcsx2 1.0.0.5435
Gsdx 5412
spu2x-r5434
lilypad
sorry for bumping this old thread,well ithout its better than make a new thread.
#9
did u try software mode by pressing F9?
#10
yes i have,it worked well but when there's a fog it will become so laggy.
i hope i can play it in hardware mode because the graphics is more clear.
anyway is there any solution to fix it in hardware mode?




Users browsing this thread: 1 Guest(s)