Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Guitar Hero: Metallica - Some songs no audio
#1
I have the game running fine except some songs there's audio, some not. I've seen it mentioned in a couple threads but no confirmation that anyone has this resolved.

So, if anyone is running this with no audio problems please let me know. I've tried all the different plugin settings I could think of with no go so far.
Win7 Ultimate x64
CPU - Intel® Core™2 Extreme CPU X9650 @ 3.6GHz
RAM - 8GB
Video - NVIDIA GeForce 9800 GT

Reply

Sponsored links

#2
pcsx2 settings and plugins.. so that we know what you're doing wrong
CPU: AMD Phenom II X2 545 processor
GPU: Nvidia GeForce 9800 GT 650 MHz
Memory: 4GB RAM DDR2
OS: Windows 7 x64
Reply
#3
(11-23-2010, 11:40 PM)Itsugawa Wrote: pcsx2 settings and plugins.. so that we know what you're doing wrong

PCSX2 build 0.9.7.3876m (svn) Oct 5 2010

[Image: pcsx2_AppSettings_Plugins.png]

All speed hacks are turned on and all the way up as advised in another post to get the game running at a good speed, and so far graphically it works great except for minor glitches here and there.

I have the SPU2-X audio plugin set to use the XAudio2 module. Latency is at the default 150ms. Synchronizing Mode is set for Async Mix which is what I've gathered you need for Guitar Hero games. I haven't disabled any effects processing so far and I've set interpolation on various different settings with no discernible difference.

On a side note, I have tried the one other audio plugin (ZeroSPU2) but the game refuses to load with it enabled.
Win7 Ultimate x64
CPU - Intel® Core™2 Extreme CPU X9650 @ 3.6GHz
RAM - 8GB
Video - NVIDIA GeForce 9800 GT

Reply
#4
And a list of which songs do that would help too probably unless it's just random Tongue2

Edit: In that case I'd suggest trying without speedhacks and setting the synchronizing mode back to timestretch and check if you get the same songs without sound, enabling all speedhacks and using a different sync mode is not recommended usually.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
My audio settings with spu2-x are:
interpolation: 1 - Linear
disable effects processing: unchecked
reverb boost factor: 1X
enable debug options: unchecked
module: 1 xAudio 2 (recommended)
latency 150 ms
syncronizing mode: TimeStretch (recommended)

With these I don't have sound issues..just low fps, some glitches here and there, but that's 'cause of my low PC specs Tongue
CPU: AMD Phenom II X2 545 processor
GPU: Nvidia GeForce 9800 GT 650 MHz
Memory: 4GB RAM DDR2
OS: Windows 7 x64
Reply
#6
Ok I'll set synch to TimeStretch... I would turn off speedhacks but the game doesn't work for me with them off. And just for confirmation Itsugawa your audio settings *do* work in Metallica?
(11-24-2010, 12:21 AM)Shadow Lady Wrote: And a list of which songs do that would help too probably unless it's just random Tongue2

So far Orion, Toxicity and Sad But True are the ones I've noticed with no audio.
Win7 Ultimate x64
CPU - Intel® Core™2 Extreme CPU X9650 @ 3.6GHz
RAM - 8GB
Video - NVIDIA GeForce 9800 GT

Reply
#7
Ok... set my audio the same as you Itsugawa still same problem... I guess I will take a closer look at my speedhacks and see which ones *may* affect audio and adjust them.

EDIT: Well, turned off speedhacks.. it did load and play although with serious slowdown. Try Toxicity, no go. Enter Sandman, A-OK. So now I'm still baffled as ever as to what the cause could be.
Win7 Ultimate x64
CPU - Intel® Core™2 Extreme CPU X9650 @ 3.6GHz
RAM - 8GB
Video - NVIDIA GeForce 9800 GT

Reply
#8
first off try not to doublepost, secondly, it could just be a compatability issue, and it's not perfect yet anyway.
Reply
#9
(11-24-2010, 03:17 AM)jbaz823 Wrote: first off try not to doublepost, secondly, it could just be a compatability issue, and it's not perfect yet anyway.

Thanks for the concern but save the snark for someone who is new to comps and emu's. And I'm well aware that it could be compat related and it's well known that pcsx2 (or any ps2 emu for that matter) is *far* from perfect in any regard.

Other than that, you got any suggestions actually related to the post that might help?
Win7 Ultimate x64
CPU - Intel® Core™2 Extreme CPU X9650 @ 3.6GHz
RAM - 8GB
Video - NVIDIA GeForce 9800 GT

Reply
#10
(11-24-2010, 12:34 AM)powbam Wrote: And just for confirmation Itsugawa your audio settings *do* work in Metallica?

Of course it works in Metallica, I'm not stupid enough to give you same settings for different games Tongue
Anyway, you maybe have the PAL version (which differs from the NTSC in fact of emulation in pcsx2) or your ISO is damaged.
CPU: AMD Phenom II X2 545 processor
GPU: Nvidia GeForce 9800 GT 650 MHz
Memory: 4GB RAM DDR2
OS: Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)