Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Guitar Hero Stuttering
#1
Hello everyone! I created this account specifically to address this issue that people (that includes me) seems to have.

After Googling all day long yesterday I was able to find a few threads including this one: http://forums.pcsx2.net/Thread-Guitar-He...-FPS-Issue

I was wondering if this was ever fixed? I've diagnosed the exact same problem as this guy. I'm able to run the game way above full speed if I turn frame limiting off. It's usually in the 100's if I have speed hacks on.

Here's a little footage I managed to capture of the issue: http://www.youtube.com/watch?v=wECmcdAtux8

Now remember, the video was rendered from a 60 fps source into a 30 fps YouTube compatible format, so there'll be some obvious stuttering that was caused by the recording and the fact that the fps was cut in half. Look closely in the beginning as well as later in the song.

It would really make my day if anyone could help me solve this, as I've just tried about everything, from various revisions of PCSX2, speed hacks, video plugins, resolutions etc. etc. A frame limiting software called RivaTuner seems to help a little though.

EDIT: Also the problem seems to occur mostly when the view is being put on the crowd, or something with a lot of graphical fidelity. However when I turn frame limiting off to see if it's because of my fps going too low, it's still in the mid 80's. If I go into the training mode where there's no venue of crowd and just a background picture of a room, the problem seems less prominent.
Reply

Sponsored links

#2
Use async audio mode, but the problem is frameskipped Smile
Reply
#3
Really? Where do I do that?

It also seems to be minimizing the issue when I turn most of the speed hacks off. However it can dip below the NTSC fps cap and the game will turn into slow motion. I also notice my CPU is only running at around 40 - 60% usage at all times. I'm running on a i5-2500k @ standard clock with a 670 GTX. Should I try overclocking my CPU and run completely without speed hacks to see if that helps too? Or is there a way to make it utilize 100% at all times?
Reply
#4
Audio plugin
Reply
#5
I'm not able to find the option you're suggesting. And I don't really understand, how is it going to help? Sorry, but my experience with these emulators are very limited.
Reply
#6
i suggest trying the MTVU speedhack, the rest of the emulator can stay at default settings.

at the moment PCSX2 is only using 2 cores of your CPU, one for the emulator + most plugins, the other for GSDX, thats why its only using 40-60%, the MTVU speedhack should bring that up to 75% ish (3 cores)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
In menu configuration-audio plugin there you find time streching than change it to async
Reply
#8
I got that async working, however I don't think it helps at all, besides syncing the audio better with the video.

And that MTVU speed hack seems to help -- been using it since yesterday, however every now and then the highway (the fretboard) still stutters. But I guess I'm gonna have to live with that for now. Will PCSX2 be able to support more than 2 cores in future releases? I mean having 4+ cores is pretty standard nowadays.
Reply
#9
Try edit your PCSX2_vm.ini try to change frameratePal to 25 (if your game pal) , frameratentsc to 30 (if your game ntsc) and change framelimiter to 200% use async audio,
Reply
#10
with mtvu it supports 3 also gsdx software mode makes quite good use of 3 cores on its own, although its much slower than hardware mode.

If your fretboard is stuttering it means the sound isn't in time with the game. are you using any of the speedhack sliders? also do you have timestretch enabled in SPU2-x?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)