Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HP Elitebook 8530p and Gran Turismo 4?
#1
Guys,

Interested in the above combo and got it somewhat running now.
Using the SSE4.1 instruction set for GSdx r4600.

I'm able to startup, to run the game with very decent FPS into the main menu. But bought a car to test driving on the speed track and then it's a pain in the ass. The FPS drops to 20-25 FPS but more over the graphics are strange coloured blocks and striped in all sort of colours***. But I can hear the car revving normally, and the HUD is also normal.
Is this related to my laptop, or some setting?

***:
[Image: normal.PNG]
[Image: test.PNG]

Specs in short.
P8600 @ 2.4Ghz
HD3650 256MB (on 128-bit bus)


Thanks!
Reply

Sponsored links

#2
Hi there. Please refer to this thread. http://forums.pcsx2.net/Thread-GranTuris...dont-exist
You will need the latest SVN build to get hardware rendering to work but your machine is on the low end. You will struggle running this game at decent speeds as it's very demanding even on good hardware. Expect around maybe 30 fps max. Good luck.
Reply
#3
Thanks, downloaded R4918.
Ticked the 8-bit textures box and native resolution. Now it's running with correct screen image Smile .
[Image: helped.png]

Only downside is, the FPS is low (quite normal for a laptop I think) but isn't there anything I can do?

EDIT:
With speedhacks enabled the sound is 'up-to-date' but the screen is lagging a bit behind still. Think I have to move to my PC (E6600 + HD4890 1GB).
Reply
#4
Nothing. According to your screenshot, your CPU was reaching its limit, and perhaps the GPU as well. This game is quite demanding.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#5
You can try unticking 8 bit textures. This doesn't really help my performance but you can give it a shot.
Also see if disabling texture filtering does anything for you. It will make it look worse but this game seems to be gpu heavy so anything thing we can do to help it along the better.
After that try your speedhacks out. Play with the preset slider at the bottom of your emulator settings and test each one out to see if you can squeeze anymore fps out. Once you get into the more aggressive hacks you can get false fps readings so just try to eyeball the best you can. I seem to get some benefit from VU stealing. Good luck.
Reply
#6
Did all the thinks you said, even the preset slider to the max. Did lower the CPU usage a bit (EE in the application title?) but as soon as I start to ride it is as bad as before. So CPU/GPU is not fast enough! But now I do got it working so going to try tomorrow on my main PC Smile . Thanks for the help so far!
Reply
#7
Did try on my old PC (E6600 + HD4890 1GB) and was running a bit faster but not noticeable for clear gaming.
Did install it on my new PC (i3 2100 + GTX560 Ti) and now it's running fine. Even have to set frame limit on or music keeps skipping so fast it's going Smile .

But, first need to get a controller because with the keyboard it's like ***. Thanks guys for the help!

PS: Running now at EE: 60%, GS: 45% and VU: 30%. Together with Bob tff on DX11 Hardware setting.
Reply
#8
I just tested this game some more and can confirm EE cycle rate and VU stealing does nothing for speed + VU stealing causes too much screen jumping. MTVU helps a bit though. I'm also using the recommended speedhacks which seemed to help maybe a little but not really enough to notice.
Reply
#9
I looked and got the following under 'Emulation Settings':
EE/IOP = all default
VUs = Claming mode @ Extra+Preserve Sign / the rest default
GS = all default
GS Window = all default
Speedhacks = EE Cyclerate @ 2 / the rest default

And that's it Smile . Game is running great now, except sometimes it has a lagg of half a second... Playing now with Rumblepad 2 and it just feels like PS2 playing. Even my dad came in and said how I could play PS2 as it wasn't turned on Tongue .

EDIT:
I do have frame limitation set to on at the GS tab (toggle with F4) otherwise I'm playing at 70 to 120 FPS and the game goes to fast Smile . But with the frame limitation on it plays perfectly!
Reply




Users browsing this thread: 1 Guest(s)